aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-29 13:00:42 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-29 13:00:42 +0000
commit60bbec4f78feb6b331449471e34401e20846abef (patch)
treefb1d8d1412ad526c857b1383c42ae79cb99f38e3 /package/busybox
parent332486205b3018969bff8510b80ec565a7cdfa5c (diff)
downloadupstream-60bbec4f78feb6b331449471e34401e20846abef.tar.gz
upstream-60bbec4f78feb6b331449471e34401e20846abef.tar.bz2
upstream-60bbec4f78feb6b331449471e34401e20846abef.zip
[package] busybox: add possibility to set crond log level through /etc/config/system and use level 5 by default which prevents unneeded debug messages on each job execution
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15481 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile2
-rwxr-xr-xpackage/busybox/files/cron3
2 files changed, 3 insertions, 2 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 0b4e3d456d..3a04637acc 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.11.3
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
diff --git a/package/busybox/files/cron b/package/busybox/files/cron
index f247130608..aa538969be 100755
--- a/package/busybox/files/cron
+++ b/package/busybox/files/cron
@@ -3,10 +3,11 @@
START=50
start () {
+ loglevel=$(/sbin/uci get "system.@system[0].cronloglevel" 2>/dev/null)
[ -z "$(ls /etc/crontabs/)" ] && exit 1
mkdir -p /var/spool/cron
[ -L /var/spool/cron/crontabs ] || ln -s /etc/crontabs /var/spool/cron/crontabs
- crond -c /etc/crontabs
+ crond -c /etc/crontabs -l ${loglevel:-5}
}
stop() {