aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-03-13 18:11:31 +0000
committerJohn Crispin <blogic@openwrt.org>2013-03-13 18:11:31 +0000
commit23f96f4fefd6c467ed9672f33154d0e17b0c65bb (patch)
tree8a8d7f8e0e7d78b46e33ab21acf61a920630e684 /package/busybox
parentb715f860d7712b66a5a353026235cccc68a38c46 (diff)
downloadupstream-23f96f4fefd6c467ed9672f33154d0e17b0c65bb.tar.gz
upstream-23f96f4fefd6c467ed9672f33154d0e17b0c65bb.tar.bz2
upstream-23f96f4fefd6c467ed9672f33154d0e17b0c65bb.zip
[busybox] make init and logread depend on !PROCD_INIT
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36005 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile2
-rw-r--r--package/busybox/config/init/Config.in1
-rw-r--r--package/busybox/config/sysklogd/Config.in2
3 files changed, 4 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 7aaaf6cb17..f4553c0ffe 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
+PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
PKG_BUILD_PARALLEL:=1
@@ -112,6 +113,7 @@ define Package/busybox/install
$(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
done
-rm -rf $(1)/lib64
+ $(if $(CONFIG_PROCD_INIT),rm -f $(1)/sbin/init $(1)/sbin/logread)
endef
$(eval $(call BuildPackage,busybox))
diff --git a/package/busybox/config/init/Config.in b/package/busybox/config/init/Config.in
index 61c20140b7..4b3c8dd160 100644
--- a/package/busybox/config/init/Config.in
+++ b/package/busybox/config/init/Config.in
@@ -73,6 +73,7 @@ config BUSYBOX_CONFIG_INIT
bool "init"
default y
select BUSYBOX_CONFIG_FEATURE_SYSLOG
+ depends on !PROCD_INIT
help
init is the first program run when the system boots.
diff --git a/package/busybox/config/sysklogd/Config.in b/package/busybox/config/sysklogd/Config.in
index 20e1aff063..087a5b4e50 100644
--- a/package/busybox/config/sysklogd/Config.in
+++ b/package/busybox/config/sysklogd/Config.in
@@ -96,7 +96,7 @@ config BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG_BUFFER_SIZE
config BUSYBOX_CONFIG_LOGREAD
bool "logread"
default y
- depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG
+ depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG && !PROCD_INIT
help
If you enabled Circular Buffer support, you almost
certainly want to enable this feature as well. This