aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-11-16 13:17:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-11-16 13:17:35 +0000
commitad5b9f001c67413636b3aaa4f6e4a83ce8f6380c (patch)
tree62fb5ac3ec83b7d5ea000e8e4819b744c41fbef1 /package/busybox
parent356170f1f74fbfa0964ca4fc82cb0b90c15ba522 (diff)
downloadupstream-ad5b9f001c67413636b3aaa4f6e4a83ce8f6380c.tar.gz
upstream-ad5b9f001c67413636b3aaa4f6e4a83ce8f6380c.tar.bz2
upstream-ad5b9f001c67413636b3aaa4f6e4a83ce8f6380c.zip
[package] busybox: fix empty password detection in telnetd init (#10432)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29183 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile2
-rwxr-xr-xpackage/busybox/files/telnet2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index a8bb67ac29..7770a538e9 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.19.3
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/busybox/files/telnet b/package/busybox/files/telnet
index 334523eb9f..994e713e70 100755
--- a/package/busybox/files/telnet
+++ b/package/busybox/files/telnet
@@ -8,7 +8,7 @@ has_root_pwd() {
pwd="${pwd#*root:}"
pwd="${pwd%%:*}"
- test -n "${pwd#!}"
+ test -n "${pwd#[\!x]}"
}
get_root_home() {