aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-11-09 17:32:23 +0000
committerNicolas Thill <nico@openwrt.org>2011-11-09 17:32:23 +0000
commit6a95c084e960176ce8e8d57435a011c6c6fc59d7 (patch)
tree61c6686630ee1de534864ee2b810d611c02a40f9 /package/busybox
parent806a25bb99337c86940764e66427c5a7e0da7d7c (diff)
downloadupstream-6a95c084e960176ce8e8d57435a011c6c6fc59d7.tar.gz
upstream-6a95c084e960176ce8e8d57435a011c6c6fc59d7.tar.bz2
upstream-6a95c084e960176ce8e8d57435a011c6c6fc59d7.zip
package/busybox: passwd: use MD5 hash by default (like it used to be)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28885 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile2
-rw-r--r--package/busybox/patches/002-passwd_use_md5_hash_by_default_like_it_used_to_be.patch20
2 files changed, 21 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index a6b6556052..871eae4ad3 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.19.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/busybox/patches/002-passwd_use_md5_hash_by_default_like_it_used_to_be.patch b/package/busybox/patches/002-passwd_use_md5_hash_by_default_like_it_used_to_be.patch
new file mode 100644
index 0000000000..ff79f3ee9c
--- /dev/null
+++ b/package/busybox/patches/002-passwd_use_md5_hash_by_default_like_it_used_to_be.patch
@@ -0,0 +1,20 @@
+From eb80c2a5315ed08bd329448217695375d89732c9 Mon Sep 17 00:00:00 2001
+From: Nicolas Thill <nico@openwrt.org>
+Date: Wed, 9 Nov 2011 18:17:20 +0100
+Subject: [PATCH] passwd: use MD5 hash by default (like it used to be)
+
+---
+ loginutils/passwd.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+--- a/loginutils/passwd.c
++++ b/loginutils/passwd.c
+@@ -94,7 +94,7 @@ int passwd_main(int argc UNUSED_PARAM, c
+ };
+ unsigned opt;
+ int rc;
+- const char *opt_a = "d"; /* des */
++ const char *opt_a = "m"; /* md5 */
+ const char *filename;
+ char *myname;
+ char *name;