aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-11-15 17:38:55 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-11-15 17:38:55 +0000
commitd0f5b51a8bd49c00d88d5ad0aa62bae322cec800 (patch)
tree67ae7a8a19d6123e147502e605835ad05a049acc /package/busybox/Makefile
parent817c72ef02d9c16b3a0021404aa9c6781382b74e (diff)
downloadupstream-d0f5b51a8bd49c00d88d5ad0aa62bae322cec800.tar.gz
upstream-d0f5b51a8bd49c00d88d5ad0aa62bae322cec800.tar.bz2
upstream-d0f5b51a8bd49c00d88d5ad0aa62bae322cec800.zip
busybox: fix hexdump segmentation fault with an empty leading format unit
SVN-Revision: 29156
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 967fa75dd1..7989345466 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.19.3
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -72,6 +72,8 @@ ifdef CONFIG_BUSYBOX_USE_LIBRPC
LDLIBS += rpc
endif
+TARGET_CFLAGS += -ggdb3
+
define Build/Compile
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \