aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
committerMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
commit7b30b70e11b8a7e90eddaa33468118bf1628a3ca (patch)
tree83f13b82bd305caf5d1c3d31f931ae8099eaf603 /package/busybox/Makefile
parentf54f9b25e1ecc50501e99d0c83843cccbc071f01 (diff)
downloadupstream-7b30b70e11b8a7e90eddaa33468118bf1628a3ca.tar.gz
upstream-7b30b70e11b8a7e90eddaa33468118bf1628a3ca.tar.bz2
upstream-7b30b70e11b8a7e90eddaa33468118bf1628a3ca.zip
From: Joseph Roback <openwrt-devel@roback.cc>
26 Makefile patches for enabling parallel builds. Tested on Linux (8-core) and Darwin (12-core), individually and from clean build_root. The first set is from trunk, the second is from feeds/packages. Signed-off-by: Joe Roback <joe@roback.cc> SVN-Revision: 22965
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 7e7e447b44..4ea9a61e4e 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -16,6 +16,8 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=7360b7138b899ee7fc885791c740c3c3
+PKG_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/package.mk
ifeq ($(DUMP),)
@@ -65,7 +67,7 @@ ifdef CONFIG_GCC_VERSION_4_5_0
endif
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
KBUILD_HAVE_NLS=no \