aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-11 05:35:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-11 05:35:46 +0000
commitfa1925c2d51d53e914ed7949418ad54377370002 (patch)
treed0e87ecd02b68c592b529f8b02f619b88292d120 /package/busybox/Makefile
parent1312f14a814d78434aee6d08a399964443dc191c (diff)
downloadupstream-fa1925c2d51d53e914ed7949418ad54377370002.tar.gz
upstream-fa1925c2d51d53e914ed7949418ad54377370002.tar.bz2
upstream-fa1925c2d51d53e914ed7949418ad54377370002.zip
add awx (awk web extension) - experimental core for a new web interface framework
SVN-Revision: 6549
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 3e6cc4e9c9..1616122c00 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -19,6 +19,7 @@ PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILDDEP:=libcgi
include $(INCLUDE_DIR)/package.mk
@@ -61,9 +62,10 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
+ EXTRA_LIBS="$(STAGING_DIR)/usr/lib/libcgi.a" \
all
endef
@@ -71,10 +73,11 @@ define Package/busybox/install
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
CONFIG_PREFIX="$(1)" \
+ EXTRA_LIBS="$(STAGING_DIR)/usr/lib/libcgi.a" \
install
$(INSTALL_DIR) $(1)/etc/init.d
for tmp in $(init-y); do \