aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-11 05:35:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-11 05:35:46 +0000
commit8513483ed3eff5521b8e4687ba289c0b8e05deed (patch)
tree52d27aa10edfb89ad332fa50d91cc0be72ab9223 /package/busybox/Makefile
parent295cf5cf94d66609f82feefe3f08e6a27765ce9f (diff)
downloadupstream-8513483ed3eff5521b8e4687ba289c0b8e05deed.tar.gz
upstream-8513483ed3eff5521b8e4687ba289c0b8e05deed.tar.bz2
upstream-8513483ed3eff5521b8e4687ba289c0b8e05deed.zip
add awx (awk web extension) - experimental core for a new web interface framework
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6549 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 3e6cc4e9c9..1616122c00 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -19,6 +19,7 @@ PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILDDEP:=libcgi
include $(INCLUDE_DIR)/package.mk
@@ -61,9 +62,10 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
+ EXTRA_LIBS="$(STAGING_DIR)/usr/lib/libcgi.a" \
all
endef
@@ -71,10 +73,11 @@ define Package/busybox/install
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
CONFIG_PREFIX="$(1)" \
+ EXTRA_LIBS="$(STAGING_DIR)/usr/lib/libcgi.a" \
install
$(INSTALL_DIR) $(1)/etc/init.d
for tmp in $(init-y); do \