aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-03 01:55:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-03 01:55:22 +0000
commitfa8238455e1274aeb6842b945a0e38cd31fdba3b (patch)
tree8f9689aa7083830fba411bbd4d5462aa90e92703 /package/busybox/Makefile
parentfb708dc2900efe7892ccf7cb4f427dd820e4cf26 (diff)
downloadupstream-fa8238455e1274aeb6842b945a0e38cd31fdba3b.tar.gz
upstream-fa8238455e1274aeb6842b945a0e38cd31fdba3b.tar.bz2
upstream-fa8238455e1274aeb6842b945a0e38cd31fdba3b.zip
busybox: only add the librpc build dependency for uclibc (#8864)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26429 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 460d28d2ef..08acc37208 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=a2ce1a951571da8c6e0eaf75b1acef60
-PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
+PKG_BUILD_DEPENDS:=BUSYBOX_USE_LIBRPC:librpc
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@@ -66,7 +66,7 @@ ifdef CONFIG_GCC_VERSION_LLVM
endif
LDLIBS:=m crypt
-ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_HAVE_RPC
+ifdef CONFIG_BUSYBOX_USE_LIBRPC
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
export LDFLAGS=$(TARGET_LDFLAGS)
LDLIBS += rpc