aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-04-21 10:03:46 +0000
committerMike Baker <mbm@openwrt.org>2006-04-21 10:03:46 +0000
commit3960174fa96b7284291d65d0c3d0f3c9c839956e (patch)
tree76b9aaa24ed9428ffe8825005a5ada7421cabc18 /package/busybox/Makefile
parent38d10e52d5e640495087acc8a2dcbd773c436acb (diff)
downloadupstream-3960174fa96b7284291d65d0c3d0f3c9c839956e.tar.gz
upstream-3960174fa96b7284291d65d0c3d0f3c9c839956e.tar.bz2
upstream-3960174fa96b7284291d65d0c3d0f3c9c839956e.zip
Add default compile target & use it for bridge and busybox
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3693 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile9
1 files changed, 0 insertions, 9 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 812e12a893..3f061b82db 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -30,15 +30,6 @@ define Build/Configure
yes '' | $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" -C $(PKG_BUILD_DIR) oldconfig
endef
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) \
- CROSS="$(TARGET_CROSS)" \
- PREFIX="$(IDIR_BUSYBOX)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
- ARCH="$(ARCH)"
-endef
-
define Package/busybox/install
$(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" PREFIX="$(1)" \
EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) install