aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-05 22:32:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-05 22:32:26 +0000
commitc8587f33254f8849b79db66b633f4b81a43db090 (patch)
treec5f05cb95397fb838b268030b8afed76e512a72b /package/broadcom-wl
parent5cdc1b304611163dbe806dc740c571852877810e (diff)
downloadupstream-c8587f33254f8849b79db66b633f4b81a43db090.tar.gz
upstream-c8587f33254f8849b79db66b633f4b81a43db090.tar.bz2
upstream-c8587f33254f8849b79db66b633f4b81a43db090.zip
install libshared into the staging dir (required by wrt-radauth)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12181 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/broadcom-wl')
-rw-r--r--package/broadcom-wl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/broadcom-wl/Makefile b/package/broadcom-wl/Makefile
index 04f2960c20..5db45cdba0 100644
--- a/package/broadcom-wl/Makefile
+++ b/package/broadcom-wl/Makefile
@@ -165,6 +165,11 @@ define Build/Compile
$(TARGET_CC) -o $(PKG_BUILD_DIR)/wl $(PKG_BUILD_DIR)/wl_exe.o
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/router/shared/libshared.a $(1)/usr/lib/
+endef
+
define Package/wlc/install
$(CP) ./files/* $(1)/
$(INSTALL_DIR) $(1)/sbin