aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-04 12:36:45 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-04 12:36:45 +0000
commit7732c5c47c801b36a7ca1826fb056809df82141c (patch)
treec1334514a40514b443cf24b33da22c2cc8880a87 /package/broadcom-wl
parent1f8e2ccbc358340d4415ceb9d6d89a4caf49a8e4 (diff)
downloadupstream-7732c5c47c801b36a7ca1826fb056809df82141c.tar.gz
upstream-7732c5c47c801b36a7ca1826fb056809df82141c.tar.bz2
upstream-7732c5c47c801b36a7ca1826fb056809df82141c.zip
[package] broadcom-wl: fix build after IRQF_SAMPLE_RANDOM flag removal (#12248)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33617 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/broadcom-wl')
-rw-r--r--package/broadcom-wl/Makefile2
-rw-r--r--package/broadcom-wl/patches/010-remove_irqf_samble_random.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/package/broadcom-wl/Makefile b/package/broadcom-wl/Makefile
index a2bd679d16..1a7da0f89d 100644
--- a/package/broadcom-wl/Makefile
+++ b/package/broadcom-wl/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=broadcom-wl
PKG_VERSION:=5.10.56.27.3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
diff --git a/package/broadcom-wl/patches/010-remove_irqf_samble_random.patch b/package/broadcom-wl/patches/010-remove_irqf_samble_random.patch
new file mode 100644
index 0000000000..27b132d115
--- /dev/null
+++ b/package/broadcom-wl/patches/010-remove_irqf_samble_random.patch
@@ -0,0 +1,11 @@
+--- a/driver/wl_linux.c 2012-09-26 20:51:48.099454971 -0400
++++ b/driver/wl_linux.c 2012-09-26 20:53:24.115453441 -0400
+@@ -691,7 +691,7 @@
+ if (wl->bustype != JTAG_BUS)
+ #endif /* BCMJTAG */
+ {
+- if (request_irq(irq, wl_isr, IRQF_SHARED|IRQF_SAMPLE_RANDOM, dev->name, wl)) {
++ if (request_irq(irq, wl_isr, IRQF_SHARED, dev->name, wl)) {
+ WL_ERROR(("wl%d: request_irq() failed\n", unit));
+ goto fail;
+ }