aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl/src/glue/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-07-24 14:10:39 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-07-24 14:10:39 +0000
commit1d7ae4aba7a252efb3fb84dce6362f99d4455b16 (patch)
treedcfd1a63124f312eea7e290b77c4f5ae6cd4fa94 /package/broadcom-wl/src/glue/Makefile
parent0df7ae04187da7634159242e29ea3201f172ef6d (diff)
downloadupstream-1d7ae4aba7a252efb3fb84dce6362f99d4455b16.tar.gz
upstream-1d7ae4aba7a252efb3fb84dce6362f99d4455b16.tar.bz2
upstream-1d7ae4aba7a252efb3fb84dce6362f99d4455b16.zip
broadcom-wl: make it work on the RT-N16 and other device using the BCMA bus - refresh and reorder patches - introduce a unified BCMA/SSB glue driver to accomodate for both bus types on brcm47xx - extend wlunbind init script to detach device from bcma-pci-bridge as well
SVN-Revision: 27751
Diffstat (limited to 'package/broadcom-wl/src/glue/Makefile')
-rw-r--r--package/broadcom-wl/src/glue/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/broadcom-wl/src/glue/Makefile b/package/broadcom-wl/src/glue/Makefile
new file mode 100644
index 0000000000..81f0c8acfd
--- /dev/null
+++ b/package/broadcom-wl/src/glue/Makefile
@@ -0,0 +1,17 @@
+#
+# Makefile for wl_glue driver
+#
+# Copyright (C) 2011 Jo-Philipp Wich <jow@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version
+# 2 of the License, or (at your option) any later version.
+#
+
+obj-m := wl_glue.o
+
+ifeq ($(MAKING_MODULES),1)
+-include $(TOPDIR)/Rules.make
+endif
+