aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl/src/glue/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-07-24 14:10:39 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-07-24 14:10:39 +0000
commit76f140409a9112440d56b9d54033d9e9ab241adf (patch)
treea885d4528a21fb5fd79e9faa59eb08878e372bb0 /package/broadcom-wl/src/glue/Makefile
parent3927d60ba3a09bafcbcd8f09be4f32ddee995458 (diff)
downloadupstream-76f140409a9112440d56b9d54033d9e9ab241adf.tar.gz
upstream-76f140409a9112440d56b9d54033d9e9ab241adf.tar.bz2
upstream-76f140409a9112440d56b9d54033d9e9ab241adf.zip
[package] broadcom-wl: make it work on the RT-N16 and other device using the BCMA bus
- refresh and reorder patches - introduce a unified BCMA/SSB glue driver to accomodate for both bus types on brcm47xx - extend wlunbind init script to detach device from bcma-pci-bridge as well git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27751 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/broadcom-wl/src/glue/Makefile')
-rw-r--r--package/broadcom-wl/src/glue/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/broadcom-wl/src/glue/Makefile b/package/broadcom-wl/src/glue/Makefile
new file mode 100644
index 0000000000..81f0c8acfd
--- /dev/null
+++ b/package/broadcom-wl/src/glue/Makefile
@@ -0,0 +1,17 @@
+#
+# Makefile for wl_glue driver
+#
+# Copyright (C) 2011 Jo-Philipp Wich <jow@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version
+# 2 of the License, or (at your option) any later version.
+#
+
+obj-m := wl_glue.o
+
+ifeq ($(MAKING_MODULES),1)
+-include $(TOPDIR)/Rules.make
+endif
+