aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl-old/src/wlcompat/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-14 11:00:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-14 11:00:30 +0000
commitb6fb8fd82131e12518ad05921f9994eeb1143001 (patch)
treec019a2ae14806f18c767eae96b3420c5a42d7246 /package/broadcom-wl-old/src/wlcompat/Makefile
parentefa4f944363ae632afee1d9bb185391558ba56c9 (diff)
downloadupstream-b6fb8fd82131e12518ad05921f9994eeb1143001.tar.gz
upstream-b6fb8fd82131e12518ad05921f9994eeb1143001.tar.bz2
upstream-b6fb8fd82131e12518ad05921f9994eeb1143001.zip
rename broadcom-wl to broadcom-wl-old
SVN-Revision: 21794
Diffstat (limited to 'package/broadcom-wl-old/src/wlcompat/Makefile')
-rw-r--r--package/broadcom-wl-old/src/wlcompat/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/package/broadcom-wl-old/src/wlcompat/Makefile b/package/broadcom-wl-old/src/wlcompat/Makefile
new file mode 100644
index 0000000000..1d18f45668
--- /dev/null
+++ b/package/broadcom-wl-old/src/wlcompat/Makefile
@@ -0,0 +1,27 @@
+#
+# Makefile for wlcompat
+#
+# Copyright (C) 2005-2007 Felix Fietkau <nbd@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version
+# 2 of the License, or (at your option) any later version.
+#
+
+EXTRA_CFLAGS += -DBCMDRIVER=1 -DBCMDMA64=1 -I../include
+ifneq ($(DEBUG),)
+ EXTRA_CFLAGS += -DDEBUG=1
+ _D=-debug
+endif
+ifneq ($(WL_WEXT),)
+ EXTRA_CFLAGS += -DWL_WEXT=1
+endif
+
+obj-m := wlcompat$(_D).o
+modules: wlcompat$(_D).o
+
+wlcompat$(_D).o: wlcompat.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS_nostdinc) -DKBUILD_BASENAME=$(subst $(comma),_,$(subst -,_,$(*F))) $(CFLAGS_$@) -c -o $@ $<
+
+-include $(TOPDIR)/Rules.make