aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-mmc/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-01-16 15:46:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-01-16 15:46:43 +0000
commit19cca88e6db70e5b7cbd5c22aa15bfa8cc1aedb1 (patch)
tree13a66b92939a1439267380fe5f1d911b1d985f44 /package/broadcom-mmc/Makefile
parenta1797e1254f7db6818a8592ce812b431d5a2468c (diff)
downloadupstream-19cca88e6db70e5b7cbd5c22aa15bfa8cc1aedb1.tar.gz
upstream-19cca88e6db70e5b7cbd5c22aa15bfa8cc1aedb1.tar.bz2
upstream-19cca88e6db70e5b7cbd5c22aa15bfa8cc1aedb1.zip
[package] remove broadcom-mmc, superseded by broadcom-sdhc
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19173 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/broadcom-mmc/Makefile')
-rw-r--r--package/broadcom-mmc/Makefile46
1 files changed, 0 insertions, 46 deletions
diff --git a/package/broadcom-mmc/Makefile b/package/broadcom-mmc/Makefile
deleted file mode 100644
index 509e993c49..0000000000
--- a/package/broadcom-mmc/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=broadcom-mmc
-PKG_VERSION:=0.1
-PKG_RELEASE:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-MAKEFLAGS_KMOD:= -C "$(LINUX_DIR)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- ARCH="$(LINUX_KARCH)" \
- PATH="$(TARGET_PATH)" \
- SUBDIRS="$(PKG_BUILD_DIR)"
-
-define KernelPackage/broadcom-mmc
- SUBMENU:=Other modules
- DEPENDS:=@TARGET_brcm_2_4
- TITLE:=Kernel driver for the Linksys WRT54G MM/SD-Card Mod
- URL:=http://kiel.kool.dk/
- FILES:=$(PKG_BUILD_DIR)/mmc.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,80,mmc)
-endef
-
-define KernelPackage/broadcom-mmc/description
- Kernel driver for the Linksys WRT54G MM/SD-Card Mod
-endef
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
- $(MAKE) $(MAKEFLAGS_KMOD) \
- modules
-endef
-
-$(eval $(call KernelPackage,broadcom-mmc))