aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-57xx/src/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-15 11:11:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-15 11:11:28 +0000
commitddd809f9e56e3a30d459d6189a1582808d204821 (patch)
tree42452684184365d849557d88c0a7155f32287ad3 /package/broadcom-57xx/src/Makefile
parent20937ce81a7807fb3506728edaaff731cee7e18c (diff)
downloadupstream-ddd809f9e56e3a30d459d6189a1582808d204821.tar.gz
upstream-ddd809f9e56e3a30d459d6189a1582808d204821.tar.bz2
upstream-ddd809f9e56e3a30d459d6189a1582808d204821.zip
(6/6) bcm57xx: package
This is the bcm57xx package. I have tested default vlan functions, but I dont have the equipment to test more advanced setups. The default vlan setup seems to be working fine. I also added the activate_gpio parameter which will make the driver activate the switch via gpio before probing for it. I'm not sure which method is best for autoload. For the wrt350n, I need the activate_gpio parameter. But its probably not a good idea to add that to the autoload file. On a system without a bcm57xx switch, isn't it a bad idea to mess with the gpios looking for the switch? Ideally, wouldn't it be best to load the bcm57xx module from broadcom-diag, after it has determined which router its on? I tried using 'request_module' from there, but had no success. For now, I am relying on preinit to load the bcm57xx module with activate_gpio param, after it has failed to load switch_robo and switch_adm. Signed-off-by: Ben Pfountz <netprince (at) vt (dot) edu> SVN-Revision: 11471
Diffstat (limited to 'package/broadcom-57xx/src/Makefile')
-rw-r--r--package/broadcom-57xx/src/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/broadcom-57xx/src/Makefile b/package/broadcom-57xx/src/Makefile
new file mode 100644
index 0000000000..08a7914879
--- /dev/null
+++ b/package/broadcom-57xx/src/Makefile
@@ -0,0 +1,17 @@
+#
+# Broadcom BCM57XX Gigabit Ethernet driver make file.
+#
+# $Id: Makefile,v 1.1.1.4 2006/09/26 02:17:12 michael Exp $
+#
+
+O_TARGET = bcm57xx.o
+
+EXTRA_CFLAGS += -DDBG=0 -DBCM_PROC_FS=1 -DT3_JUMBO_RCV_RCB_ENTRY_COUNT=256
+EXTRA_CFLAGS += -DPCIX_TARGET_WORKAROUND=1 -DINCLUDE_TBI_SUPPORT=1 -DINCLUDE_5701_AX_FIX=1
+
+export-objs :=
+
+obj-y := b57um.o tigon3.o autoneg.o 5701rls.o tcp_seg.o hndgige.o bcmrobo.o
+obj-m := $(O_TARGET)
+
+include $(TOPDIR)/Rules.make