aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2022-02-04 16:17:03 +0200
committerPetr Štetiar <ynezz@true.cz>2022-02-24 19:05:29 +0100
commit3e53eec58958b56c1be02d001f4b51dfb1714525 (patch)
tree3cf62b04d4318b6564e84bb630020a1cff532668 /package/boot
parente58cd453d58b20c6a6f34d3591640aa19aa14d25 (diff)
downloadupstream-3e53eec58958b56c1be02d001f4b51dfb1714525.tar.gz
upstream-3e53eec58958b56c1be02d001f4b51dfb1714525.tar.bz2
upstream-3e53eec58958b56c1be02d001f4b51dfb1714525.zip
at91: add support for sama7g5-ek board
Add support for SAMA7G5-EK board. Hardware: - SoC: SAMA7G5 - RAM: Aliance Memory AS4C256M16D3LC (4 Gbit DDR3L) - SD/MMC: 1 standard 4bit SD Card interface - USB: 1 Micro-AB host/device, 1 Type-A host, 1 Type-C host - CAN: 2 interfaces - Ethernet: 10/100 port, 1Gbps port - Wi-Fi/BT: 1 optional interface - Audio: 1 SPDIF RX port, 1 SPDIF TX port, 4 digital microphones - Camera: 1 RPi CSI camera interface - Debug: 1 J-Link-OB + CDC, 1 JTAG - LEDs: 1 RGB - Buttons: 4 push buttons - Expansions: 1 RPi Expansion connector, 2 mikroBUS connectors - Power management: 1 power management IC, 1 power consumption measurement device Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/at91bootstrap/Makefile9
-rw-r--r--package/boot/uboot-at91/Makefile9
2 files changed, 16 insertions, 2 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 92dbf27a1e..72afefdfff 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -172,6 +172,12 @@ define AT91Bootstrap/sama5d2_ptc_eksd_uboot
BUILD_DEVICES:=microchip_sama5d2-ptc-ek
endef
+define AT91Bootstrap/sama7g5eksd_uboot
+ TITLE:=AT91Bootstrap for SAMA7G5-EK (SDCard)
+ BUILD_SUBTARGET:=sama7
+ BUILD_DEVICES:=microchip_sama7g5-ek
+endef
+
AT91BOOTSTRAP_TARGETS := \
at91sam9x5eknf_uboot \
at91sam9x5eksd_uboot \
@@ -192,7 +198,8 @@ AT91BOOTSTRAP_TARGETS := \
sama5d27_wlsom1_eksd_uboot \
sama5d27_wlsom1_ekdf_qspi_uboot \
sama5d2_ptc_eknf_uboot \
- sama5d2_ptc_eksd_uboot
+ sama5d2_ptc_eksd_uboot \
+ sama7g5eksd_uboot
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 7052329ecd..ed69b8b06c 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -143,6 +143,12 @@ define U-Boot/sama5d2_ptc_ek_mmc
BUILD_DEVICES:=microchip_sama5d2-ptc-ek
endef
+define U-Boot/sama7g5ek_mmc1
+ NAME:=SAMA7G5-EK (SDCard)
+ BUILD_SUBTARGET:=sama7
+ BUILD_DEVICES:=microchip_sama7g5-ek
+endef
+
UBOOT_TARGETS := \
at91sam9m10g45ek_nandflash \
at91sam9x5ek_nandflash \
@@ -162,7 +168,8 @@ UBOOT_TARGETS := \
sama5d27_wlsom1_ek_mmc \
sama5d27_wlsom1_ek_qspiflash \
sama5d2_ptc_ek_nandflash \
- sama5d2_ptc_ek_mmc
+ sama5d2_ptc_ek_mmc \
+ sama7g5ek_mmc1
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \