aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2021-01-18 09:00:42 +0100
committerPetr Štetiar <ynezz@true.cz>2022-08-28 08:12:39 +0200
commit052ff08aa7ec8d39677fcaccaa74fe2d13ef0384 (patch)
tree15bf570b0d3d5e60aa84cc4a800097be29503a05 /package/boot
parentcaeb618eea9c327d801f0e16eb3ed930f567481d (diff)
downloadupstream-052ff08aa7ec8d39677fcaccaa74fe2d13ef0384.tar.gz
upstream-052ff08aa7ec8d39677fcaccaa74fe2d13ef0384.tar.bz2
upstream-052ff08aa7ec8d39677fcaccaa74fe2d13ef0384.zip
sunxi: add support for Banana Pi M2 Berry
CPU: Allwinner V40 quad-core Cortex A7 @ 1.2GHz Memory: 1GB DDR3 Storage: SDcard, native SATA Network: 10/100/1000M ethernet, Ampak AP6212 wifi + BT USB: 4x USB 2.0 Installation: Use the standard sunxi installation to an SD-card. While the board is very similar to the M2 Ultra board (the V40 is the automotive version of the R40), as both the u-boot and kernel supports them separately, and some pins are different, let's add a separate device spec. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> (cherry picked from commit 9aa66b8ce730aebff76d353392151708a897a3a0)
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 38147339a4..1358da5dfb 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -301,6 +301,12 @@ define U-Boot/Bananapi_M2_Ultra
BUILD_DEVICES:=sinovoip_bananapi-m2-ultra
endef
+define U-Boot/bananapi_m2_berry
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Bananapi M2 Berry
+ BUILD_DEVICES:=sinovoip_bananapi-m2-berry
+endef
+
UBOOT_TARGETS := \
a64-olinuxino \
a64-olinuxino-emmc \
@@ -312,6 +318,7 @@ UBOOT_TARGETS := \
A20-OLinuXino_MICRO \
bananapi_m2_plus_h3 \
Bananapi \
+ bananapi_m2_berry \
Bananapi_M2_Ultra \
Bananapro \
Cubieboard \