aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-06-15 14:57:14 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-04 13:15:40 +0200
commit1754dc2ddba23453da158a8430f7f31b7dfe26d9 (patch)
treece407f66782c8bea90e5613d9e2b19702a6b5617 /package/boot
parente7ccc34478965654fe9b89e5cefac955d18f53de (diff)
downloadupstream-1754dc2ddba23453da158a8430f7f31b7dfe26d9.tar.gz
upstream-1754dc2ddba23453da158a8430f7f31b7dfe26d9.tar.bz2
upstream-1754dc2ddba23453da158a8430f7f31b7dfe26d9.zip
treewide: fix syntax errors exposed after kconfig update
After commit e82a4d9cfb ("config: regenerate *_shipped sources") the mconf parser became more strict as a side effect and started to spew a series of warnings when evaluating our generated kconfig sources: tmp/.config-package.in:705:warning: ignoring unsupported character '@' The root cause of these warnings is a wrong use of the @SYMBOL dependency syntax in various Makefile. Fix the corresponding Makefiles by turning `@SYM||@SYM2` expressions into the proper `@(SYM||SYM2)` form. Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit 74739c4228f3bd0aa757165c67c53016c3deb544)
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/kexec-tools/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index 76ea46f10f..ca41839869 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -44,7 +44,7 @@ define Package/kexec
$(call Package/kexec-tools/Default)
TITLE:=Kernel boots kernel
DEPENDS:=\
- @armeb||@arm||@i386||@x86_64||@powerpc64||@mipsel||@mips \
+ @(armeb||arm||i386||x86_64||powerpc64||mipsel||mips) \
+KEXEC_ZLIB:zlib +KEXEC_LZMA:liblzma @KERNEL_KEXEC
endef
@@ -55,7 +55,7 @@ endef
define Package/kdump
$(call Package/kexec-tools/Default)
TITLE:=Kernel crash analysis
- DEPENDS:=+kexec @i386||@x86_64||@arm @KERNEL_CRASH_DUMP
+ DEPENDS:=+kexec @(i386||x86_64||arm) @KERNEL_CRASH_DUMP
endef
define Package/kdump/description