aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-03-25 15:15:01 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-03 21:27:12 +0200
commite6f9a8e89b0a95599d2c342bd878ec63b13e4f90 (patch)
treee80bc92410963e3adb90d0ec3889b5b73ca4a400 /package/boot
parentc35425f4182e90601fa2c2f38b21a54eb49793ad (diff)
downloadupstream-e6f9a8e89b0a95599d2c342bd878ec63b13e4f90.tar.gz
upstream-e6f9a8e89b0a95599d2c342bd878ec63b13e4f90.tar.bz2
upstream-e6f9a8e89b0a95599d2c342bd878ec63b13e4f90.zip
au1000: Remove unmaintained target
This target only supports kernel 3.18, which is not supported in OpenWrt any more for multiple releases. It also looks like there is no active maintainer for this target. Remove the code and all the packages which are only used by this target. To add this target to OpenWrt again port it to a recent and supported kernel version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/yamonenv/Makefile41
-rw-r--r--package/boot/yamonenv/patches/001-yamonenv_mtd_partition.patch11
2 files changed, 0 insertions, 52 deletions
diff --git a/package/boot/yamonenv/Makefile b/package/boot/yamonenv/Makefile
deleted file mode 100644
index ef1f36de65..0000000000
--- a/package/boot/yamonenv/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=yamonenv
-PKG_VERSION:=20051022
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)_gruen.4g__$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
-PKG_HASH:=466eca9cdad2c15e957fb9ce7d0b6927ecd17d85c4cc2dff37e97a3e6b209c67
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-
-PKG_FLAGS:=nonshared
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/yamonenv
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=Boot Loaders
- DEPENDS:=@TARGET_au1000
- TITLE:=YAMON configuration utility
- MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-endef
-
-define Build/Configure
-endef
-
-define Package/yamonenv/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,yamonenv))
diff --git a/package/boot/yamonenv/patches/001-yamonenv_mtd_partition.patch b/package/boot/yamonenv/patches/001-yamonenv_mtd_partition.patch
deleted file mode 100644
index e1def28af5..0000000000
--- a/package/boot/yamonenv/patches/001-yamonenv_mtd_partition.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/yamonenv.c
-+++ b/src/yamonenv.c
-@@ -12,7 +12,7 @@
- #include <fcntl.h>
- #include <unistd.h>
-
--#define DEFAULT_YAMON_ENV_FILE "/dev/mtd/3"
-+#define DEFAULT_YAMON_ENV_FILE "/dev/mtd3"
-
-
- // control byte definitions: