aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-29 10:59:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-29 10:59:51 +0000
commitf6b57149af3edf52773f9c3abf5e5e0454bcb49c (patch)
tree7606e2550f2bb769a33e8f7f3dae3546c6146603 /package/boot
parent08a62d8d8a355e9589106309926a18ffb92a9761 (diff)
downloadupstream-f6b57149af3edf52773f9c3abf5e5e0454bcb49c.tar.gz
upstream-f6b57149af3edf52773f9c3abf5e5e0454bcb49c.tar.bz2
upstream-f6b57149af3edf52773f9c3abf5e5e0454bcb49c.zip
FPU type should not interfere with the ABI selection. Also make sure we either do real soft-float or hard-float on ARM, with the right options.
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38943
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-omap/Makefile2
-rw-r--r--package/boot/uboot-sunxi/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index 45d32bd3c3..96168a30d0 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -71,7 +71,7 @@ endif
define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) \
- $(UBOOT_CONFIG)_config
+ USE_PRIVATE_LIBGCC=yes $(UBOOT_CONFIG)_config
endef
define Build/Compile
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index da729dd969..2041ffc4be 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -73,7 +73,7 @@ endif
define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) \
- $(UBOOT_CONFIG)_config
+ USE_PRIVATE_LIBGCC=yes $(UBOOT_CONFIG)_config
endef
define Build/Compile