aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorBiwen Li <biwen.li@nxp.com>2019-05-06 11:26:09 +0800
committerPetr Štetiar <ynezz@true.cz>2019-06-06 15:40:09 +0200
commitc07d3302b3cd4fc50ff380239f4541df7526df82 (patch)
tree42d639418c68700fa1609458f432aa8fa75d22c3 /package/boot
parent17dcbe1b8e2b7074ab1822f117e48a5c04997e4a (diff)
downloadupstream-c07d3302b3cd4fc50ff380239f4541df7526df82.tar.gz
upstream-c07d3302b3cd4fc50ff380239f4541df7526df82.tar.bz2
upstream-c07d3302b3cd4fc50ff380239f4541df7526df82.zip
layerscape: convert to use TF-A for firmware
This patch is to convert to use TF-A for firmware. - Use un-swapped rcw since swapping will be done in TF-A. - Use u-boot with TF-A defconfig. - Rework memory map for TF-A introduction. Signed-off-by: Biwen Li <biwen.li@nxp.com> Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-layerscape/Makefile24
-rw-r--r--package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt2
-rw-r--r--package/boot/uboot-layerscape/files/ls1043ardb-uEnv.txt2
-rw-r--r--package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt2
-rw-r--r--package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt2
-rw-r--r--package/boot/uboot-layerscape/files/ls2088ardb-uEnv.txt2
6 files changed, 17 insertions, 17 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index 3630ecf120..ddf71bd986 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -29,52 +29,52 @@ endef
define U-Boot/ls1012ardb
NAME:=NXP LS1012ARDB
- UBOOT_CONFIG:=ls1012ardb_qspi
+ UBOOT_CONFIG:=ls1012ardb_tfa
ENV_SIZE:=0x40000
endef
define U-Boot/ls1012afrwy
NAME:=NXP LS1012AFRWY
- UBOOT_CONFIG:=ls1012afrwy_qspi
+ UBOOT_CONFIG:=ls1012afrwy_tfa
ENV_SIZE:=0x10000
endef
define U-Boot/ls1043ardb
NAME:=NXP LS1043ARDB
- ENV_SIZE:=0x20000
+ UBOOT_CONFIG:=ls1043ardb_tfa
endef
define U-Boot/ls1043ardb-sdboot
NAME:=NXP LS1043ARDB SD Card Boot
- UBOOT_CONFIG:=ls1043ardb_sdcard
- UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+ UBOOT_CONFIG:=ls1043ardb_tfa
endef
+
define U-Boot/ls1046ardb
NAME:=NXP LS1046ARDB
- UBOOT_CONFIG:=ls1046ardb_qspi
+ UBOOT_CONFIG:=ls1046ardb_tfa
endef
define U-Boot/ls1046ardb-sdboot
NAME:=NXP LS1046ARDB SD Card Boot
- UBOOT_CONFIG:=ls1046ardb_sdcard
- UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+ UBOOT_CONFIG:=ls1046ardb_tfa
endef
+
define U-Boot/ls1088ardb
NAME:=NXP LS1088ARDB
- UBOOT_CONFIG:=ls1088ardb_qspi
+ UBOOT_CONFIG:=ls1088ardb_tfa
endef
+
define U-Boot/ls1088ardb-sdboot
NAME:=NXP LS1088ARDB SD Card Boot
- UBOOT_CONFIG:=ls1088ardb_sdcard_qspi
- UBOOT_IMAGE:=u-boot-with-spl.bin
+ UBOOT_CONFIG:=ls1088ardb_tfa
endef
define U-Boot/ls2088ardb
NAME:=NXP LS2088ARDB
- UBOOT_CONFIG:=ls2080ardb
+ UBOOT_CONFIG:=ls2088ardb_tfa
endef
define U-Boot/ls1021atwr
diff --git a/package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt b/package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt
index 32419dd33d..b5faeb255a 100644
--- a/package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt
+++ b/package/boot/uboot-layerscape/files/ls1012ardb-uEnv.txt
@@ -3,6 +3,6 @@ loadaddr=0x81000000
fdt_high=0xffffffffffffffff
initrd_high=0xffffffffffffffff
qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000 1000000;bootm $loadaddr - $fdtaddr
-bootargs=ubi.mtd=9 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.quadspi:1m(rcw),2m(u-boot),1m(u-boot-env),2m(ppa),4m(reserved-1),3m(pfe),2m(reserved-2),1m(dtb),16m(kernel),32m(ubifs)
+bootargs=ubi.mtd=8 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.quadspi:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(pfe),2m(reserved-2),1m(dtb),16m(kernel),32m(ubifs)
bootcmd=echo starting openwrt ...;pfe stop;run qspi_boot
bootdelay=3
diff --git a/package/boot/uboot-layerscape/files/ls1043ardb-uEnv.txt b/package/boot/uboot-layerscape/files/ls1043ardb-uEnv.txt
index c78bfe0098..b040cffdbf 100644
--- a/package/boot/uboot-layerscape/files/ls1043ardb-uEnv.txt
+++ b/package/boot/uboot-layerscape/files/ls1043ardb-uEnv.txt
@@ -4,6 +4,6 @@ fdt_high=0xffffffffffffffff
initrd_high=0xffffffffffffffff
hwconfig=fsl_ddr:bank_intlv=auto
nor_boot=cp.b 60f00000 $fdtaddr 100000;cp.b 61000000 $loadaddr 1000000;bootm $loadaddr - $fdtaddr
-bootargs=root=/dev/mtdblock9 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=60000000.nor:1m(rcw),2m(u-boot),1m(u-boot-env),2m(ppa),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(rootfs)
+bootargs=root=/dev/mtdblock8 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=60000000.nor:1m(bl2),4m(fip),1m(u-boot-env),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(rootfs)
bootcmd=echo starting openwrt ...;run nor_boot
bootdelay=3
diff --git a/package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt b/package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt
index fecb8fd702..ad3a3d6c37 100644
--- a/package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt
+++ b/package/boot/uboot-layerscape/files/ls1046ardb-uEnv.txt
@@ -4,6 +4,6 @@ fdt_high=0xffffffffffffffff
initrd_high=0xffffffffffffffff
hwconfig=fsl_ddr:bank_intlv=auto
qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000 1000000;bootm $loadaddr - $fdtaddr
-bootargs=ubi.mtd=10 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.quadspi:1m(rcw),2m(u-boot),1m(u-boot-env),2m(ppa),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(ubifs)
+bootargs=ubi.mtd=9 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.quadspi:1m(bl2),4m(fip),1m(u-boot-env),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(ubifs)
bootcmd=echo starting openwrt ...;run qspi_boot
bootdelay=3
diff --git a/package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt b/package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt
index 1bcd7019cc..eb2c443b39 100644
--- a/package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt
+++ b/package/boot/uboot-layerscape/files/ls1088ardb-uEnv.txt
@@ -5,6 +5,6 @@ initrd_high=0xffffffffffffffff
hwconfig=fsl_ddr:bank_intlv=auto
mc_init=sf probe 0:0;sf read 80000000 a00000 300000;sf read 80300000 e00000 100000;fsl_mc start mc 80000000 80300000;sf read 80400000 d00000 100000;fsl_mc apply dpl 80400000
qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000 1000000;bootm $loadaddr - $fdtaddr
-bootargs=ubi.mtd=11 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=20c0000.quadspi:1m(rcw),2m(u-boot),1m(u-boot-env),2m(ppa),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(ubifs)
+bootargs=ubi.mtd=10 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=20c0000.quadspi:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(ubifs)
bootcmd=echo starting openwrt ...;run mc_init;run qspi_boot
bootdelay=3
diff --git a/package/boot/uboot-layerscape/files/ls2088ardb-uEnv.txt b/package/boot/uboot-layerscape/files/ls2088ardb-uEnv.txt
index f3b6725544..31e937ffcb 100644
--- a/package/boot/uboot-layerscape/files/ls2088ardb-uEnv.txt
+++ b/package/boot/uboot-layerscape/files/ls2088ardb-uEnv.txt
@@ -5,6 +5,6 @@ initrd_high=0xffffffffffffffff
hwconfig=fsl_ddr:bank_intlv=auto
mc_init=fsl_mc start mc 580a00000 580e00000;fsl_mc apply dpl 580d00000
nor_boot=cp.b 580f00000 $fdtaddr 100000;cp.b 581000000 $loadaddr 1000000;bootm $loadaddr - $fdtaddr
-bootargs=root=/dev/mtdblock10 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS1,115200 mtdparts=580000000.nor:1m(rcw),2m(u-boot),1m(u-boot-env),2m(ppa),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(rootfs)
+bootargs=root=/dev/mtdblock9 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS1,115200 mtdparts=580000000.nor:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(rootfs)
bootcmd=echo starting openwrt ...;run mc_init;run nor_boot
bootdelay=3