aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-05-23 09:15:52 +0200
committerJo-Philipp Wich <jo@mein.io>2018-05-23 09:29:28 +0200
commit68586cf233756de9786cca8df0dc78b6ed98375e (patch)
treea321527c3138b59a06f2e8db7e5c02e1a095fffd /package/boot
parent938908f400aaf279ddd4ff4a2e630a2d9d603080 (diff)
downloadupstream-68586cf233756de9786cca8df0dc78b6ed98375e.tar.gz
upstream-68586cf233756de9786cca8df0dc78b6ed98375e.tar.bz2
upstream-68586cf233756de9786cca8df0dc78b6ed98375e.zip
uboot-mxs: fix build on hosts lacking pkg-config
The uboot-mvebu package incorrectly used the host pkg-config for the tool build parts, which broke the build on systems lacking pkg-config and only worked by accident on those that have it installed. Export the host-build specific environment variables for the uboot build to redirect pkg-config invocations to our staged host build pkg-config in buildroot. Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit 208b984dda0c2348d425b992b9a1c171d5aaa8e8)
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-mxs/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index cd752bb81a..5636dcfbb4 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -15,6 +15,7 @@ PKG_HASH:=6a018fd3caf58f3dcfa23ee989a82bd35df03af71872b9dca8c6d758a0d26c05
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define U-Boot/Default
BUILD_TARGET:=mxs
@@ -37,6 +38,8 @@ UBOOT_TARGETS := \
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)
+Build/Exports:=$(Host/Exports)
+
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)