aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-zynq
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2018-05-13 18:12:21 -0400
committerJohn Crispin <john@phrozen.org>2018-06-07 09:00:49 +0200
commit8c8499f0ea790fdf69547d868803a29da6d0e7bd (patch)
tree0823120721177cb7d433e6bd814dc3ddb7bcdbbe /package/boot/uboot-zynq
parent61b977fa2cc30ad3ef7a1975cdc60bb86c550958 (diff)
downloadupstream-8c8499f0ea790fdf69547d868803a29da6d0e7bd.tar.gz
upstream-8c8499f0ea790fdf69547d868803a29da6d0e7bd.tar.bz2
upstream-8c8499f0ea790fdf69547d868803a29da6d0e7bd.zip
uboot-zynq: update to 2017.03
Compile-tested: ZedBoard Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'package/boot/uboot-zynq')
-rw-r--r--package/boot/uboot-zynq/Makefile6
-rw-r--r--package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch4
2 files changed, 5 insertions, 5 deletions
diff --git a/package/boot/uboot-zynq/Makefile b/package/boot/uboot-zynq/Makefile
index 736ebd26da..f2c0769ead 100644
--- a/package/boot/uboot-zynq/Makefile
+++ b/package/boot/uboot-zynq/Makefile
@@ -7,9 +7,9 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=2016.03
+PKG_VERSION:=2017.03
-PKG_HASH:=e49337262ecac44dbdeac140f2c6ebd1eba345e0162b0464172e7f05583ed7bb
+PKG_HASH:=f54baf3f9325bf444c7905f3a5b6f83680edb1e6e1a4d5f8a5ad80abe885113f
include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/u-boot.mk
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/host-build.mk
define U-Boot/Default
BUILD_TARGET:=zynq
- UBOOT_IMAGE:=u-boot u-boot-dtb.bin u-boot.dtb u-boot-dtb.img spl/boot.bin spl/u-boot-spl spl/u-boot-spl-dtb.bin
+ UBOOT_IMAGE:=spl/boot.bin u-boot.img
UBOOT_CONFIG:=zynq_$(1)
endef
diff --git a/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch b/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
index a260e84e80..3a32ea1eb9 100644
--- a/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
+++ b/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
@@ -3,9 +3,9 @@ needed dependencies are added too.
--- a/tools/Makefile
+++ b/tools/Makefile
-@@ -128,7 +128,7 @@ endif
+@@ -152,7 +152,7 @@ endif
# MXSImage needs LibSSL
- ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_FIT_SIGNATURE),)
+ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_ARMADA_38X)$(CONFIG_ARMADA_39X)$(CONFIG_FIT_SIGNATURE),)
HOSTLOADLIBES_mkimage += \
- $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
+ $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")