aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-zynq
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2018-09-03 22:39:58 -0300
committerJohn Crispin <john@phrozen.org>2018-09-10 08:54:25 +0200
commit306a60fcfed2481498a05b9e016cba4abcfd1343 (patch)
tree5448f68e17fb11b030431ebf84f22ca9b40ad78b /package/boot/uboot-zynq
parente62df3dd8b5efcbddf278c12f5d85faf4ac38e22 (diff)
downloadupstream-306a60fcfed2481498a05b9e016cba4abcfd1343.tar.gz
upstream-306a60fcfed2481498a05b9e016cba4abcfd1343.tar.bz2
upstream-306a60fcfed2481498a05b9e016cba4abcfd1343.zip
uboot-zynq: copy U-Boot images to STAGING_DIR
Create a directory inside STAGING_DIR and copy U-Boot output images, so they can be used later when creating the sdcard image Additionally, like others targets, override the default install method to avoid copying the images to bin directory Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'package/boot/uboot-zynq')
-rw-r--r--package/boot/uboot-zynq/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/boot/uboot-zynq/Makefile b/package/boot/uboot-zynq/Makefile
index c4779249c4..31575d7cae 100644
--- a/package/boot/uboot-zynq/Makefile
+++ b/package/boot/uboot-zynq/Makefile
@@ -49,6 +49,15 @@ UBOOT_TARGETS := \
zybo \
zybo_z7
+define Build/InstallDev
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(CP) $(PKG_BUILD_DIR)/spl/boot.bin $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-boot.bin
+ $(CP) $(PKG_BUILD_DIR)/u-boot.img $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-u-boot.img
+endef
+
+define Package/u-boot/install/default
+endef
+
Build/Exports:=$(Host/Exports)
$(eval $(call BuildPackage/U-Boot))