aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-xburst/files/board/sakc/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-10-16 13:44:25 +0000
committerJohn Crispin <john@openwrt.org>2012-10-16 13:44:25 +0000
commite75106aa0d82a64122954b5990b50ec80d8e4040 (patch)
treebcc8ab60e849b3a0debb601b13c7f5356d9683e8 /package/boot/uboot-xburst/files/board/sakc/Makefile
parent254d851d8a9434e9c8a12a6ec96538ba13101600 (diff)
downloadupstream-e75106aa0d82a64122954b5990b50ec80d8e4040.tar.gz
upstream-e75106aa0d82a64122954b5990b50ec80d8e4040.tar.bz2
upstream-e75106aa0d82a64122954b5990b50ec80d8e4040.zip
move boot related packages to their own folder
SVN-Revision: 33781
Diffstat (limited to 'package/boot/uboot-xburst/files/board/sakc/Makefile')
-rw-r--r--package/boot/uboot-xburst/files/board/sakc/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/boot/uboot-xburst/files/board/sakc/Makefile b/package/boot/uboot-xburst/files/board/sakc/Makefile
new file mode 100644
index 0000000000..470447d450
--- /dev/null
+++ b/package/boot/uboot-xburst/files/board/sakc/Makefile
@@ -0,0 +1,38 @@
+#
+# (C) Copyright 2006
+# Ingenic Semiconductor, <jlwei@ingenic.cn>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA 02111-1307 USA
+#
+
+include $(TOPDIR)/config.mk
+
+LIB = lib$(BOARD).a
+
+OBJS = $(BOARD).o
+SOBJS =
+
+$(LIB): .depend $(OBJS) $(SOBJS)
+ $(AR) crv $@ $(OBJS) $(SOBJS)
+
+#########################################################################
+
+.depend: Makefile $(SOBJS:.o=.S) $(OBJS:.o=.c)
+ $(CC) -M $(CFLAGS) $(SOBJS:.o=.S) $(OBJS:.o=.c) > $@
+
+sinclude .depend
+
+#########################################################################