aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-xburst/Makefile
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2013-01-07 14:10:01 +0000
committerMirko Vogt <mirko@openwrt.org>2013-01-07 14:10:01 +0000
commit12a6622bd938614b9758d20d136c78a0c67e7155 (patch)
tree7d85ef4c53b7d36975b36a83369786d622f8c268 /package/boot/uboot-xburst/Makefile
parentc86485210ba6136bc90fc2708611ae5a609b6bf1 (diff)
downloadupstream-12a6622bd938614b9758d20d136c78a0c67e7155.tar.gz
upstream-12a6622bd938614b9758d20d136c78a0c67e7155.tar.bz2
upstream-12a6622bd938614b9758d20d136c78a0c67e7155.zip
This patch updates uboot-xburst from 2009.11 to 2012.10-rc2 - Ingenic SoC support went upstream
Summary: * remove all files/* (since merged to upstream) * patches on nand-spl, mmc and lcd driver Thanks a lot to Xiangfu Liu! Signed-off-by: Xiangfu Liu <xiangfu@sharism.cc> SVN-Revision: 35034
Diffstat (limited to 'package/boot/uboot-xburst/Makefile')
-rw-r--r--package/boot/uboot-xburst/Makefile33
1 files changed, 7 insertions, 26 deletions
diff --git a/package/boot/uboot-xburst/Makefile b/package/boot/uboot-xburst/Makefile
index 1d340fd5e1..1115d255c3 100644
--- a/package/boot/uboot-xburst/Makefile
+++ b/package/boot/uboot-xburst/Makefile
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=u-boot
-PKG_VERSION:=2009.11
+PKG_VERSION:=2012.10-rc2
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=
+PKG_MD5SUM:=451c07271940016cec6f5ad8a155263b
PKG_TARGETS:=bin
include $(INCLUDE_DIR)/package.mk
@@ -30,20 +30,7 @@ define uboot/qi_lb60
TITLE:=U-boot for the qi_lb60 board
endef
-define uboot/avt2
- TITLE:=U-boot for the avt2 board
-endef
-
-define uboot/sakc
- TITLE:=U-boot for the sakc board
-endef
-
-define uboot/n516
- TITLE:=U-boot for the N516 e-book reader
- CONFIG:=n516_nand
-endef
-
-UBOOTS:=qi_lb60 n516 avt2 sakc
+UBOOTS:=qi_lb60
define Package/uboot/template
define Package/uboot-xburst-$(1)
@@ -51,7 +38,7 @@ define Package/uboot-xburst-$(1)
CATEGORY:=Boot Loaders
DEPENDS:=@TARGET_xburst
TITLE:=$(2)
- URL:=http://www.denx.de/wiki/U-Boot
+ URL:=http://www.denx.de/wiki/UBoot/WebHome
VARIANT:=$(1)
endef
endef
@@ -66,15 +53,9 @@ endef
ifdef BUILD_VARIANT
$(eval $(call uboot/$(BUILD_VARIANT)))
UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
+UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_BARIANT)-u-boot.bin)
endif
-define Build/Prepare
- $(call Build/Prepare/Default)
- $(CP) ./files/* $(PKG_BUILD_DIR)
- find $(PKG_BUILD_DIR) -name .svn | $(XARGS) rm -rf
-endef
-
define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) \
$(UBOOT_CONFIG)_config
@@ -87,8 +68,8 @@ endef
define Package/uboot/install/template
define Package/uboot-xburst-$(1)/install
- $(INSTALL_DIR) $$(1)
- $(CP) $(PKG_BUILD_DIR)/u-boot-nand.bin $(BIN_DIR)/$(2)
+ $(CP) $(PKG_BUILD_DIR)/u-boot-xburst.bin $(BIN_DIR)/$(2)
+ rmdir $$(1)
endef
endef