aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-27 16:18:05 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-27 16:53:31 +0100
commitcf3d1b61bfc3f2dd6affe6e59019801d00f7f85f (patch)
treed290d77099ea37a2d1128e7d24bc3b989a874f45 /package/boot/uboot-sunxi
parentc6502ce3bb87b6a6a85209d3e67736bd2db21bc7 (diff)
downloadupstream-cf3d1b61bfc3f2dd6affe6e59019801d00f7f85f.tar.gz
upstream-cf3d1b61bfc3f2dd6affe6e59019801d00f7f85f.tar.bz2
upstream-cf3d1b61bfc3f2dd6affe6e59019801d00f7f85f.zip
sunxi: put u-boot images into image staging directory
Do not put the u-boot images into the kernel build directory as this directory might get removed after kernel updates while the u-boot packages InstallDev recipe is not getting re-executed because it is still considered current, leading to image build failures later on due to missing images. To ensure that built bootloader images persist over kernel version updates in the buildroot, put them into the new STAGING_DIR_IMAGE directory. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/boot/uboot-sunxi')
-rw-r--r--package/boot/uboot-sunxi/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 311437a0af..bb58104d06 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -131,9 +131,10 @@ UBOOT_TARGETS := \
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
define Build/InstallDev
- $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_DEVICES)-u-boot-with-spl.bin
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-u-boot-with-spl.bin
mkimage -C none -A arm -T script -d uEnv-$(UENV).txt \
- $(KERNEL_BUILD_DIR)/$(BUILD_DEVICES)-boot.scr
+ $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-boot.scr
endef
define Package/u-boot/install/default