aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2017-10-23 22:33:00 +0200
committerJohn Crispin <john@phrozen.org>2017-11-06 16:39:41 +0100
commitf9ecb0d562bd1dab9dadb150f6a6c146b948fc5c (patch)
tree2b9366aa0d886f35e7b867f364b43da2fdfdb01a /package/boot/uboot-sunxi
parente555153807777539c9b97f8d13563135592d68e7 (diff)
downloadupstream-f9ecb0d562bd1dab9dadb150f6a6c146b948fc5c.tar.gz
upstream-f9ecb0d562bd1dab9dadb150f6a6c146b948fc5c.tar.bz2
upstream-f9ecb0d562bd1dab9dadb150f6a6c146b948fc5c.zip
sunxi: add Orange Pi 2 support
- H3 @ 1.3 GHz - 1GiB DDR3 - 10/100Mbps Ethernet - Realtek RTL8189ETV wifi - 4 USB 2.0 Difference to the "Orange Pi Plus" is the lack of Gbit ethernet and lack of onboard flash. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package/boot/uboot-sunxi')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index d986f6259c..c5337c93ec 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -150,6 +150,12 @@ define U-Boot/orangepi_plus
BUILD_DEVICES:=sun8i-h3-orangepi-plus
endef
+define U-Boot/orangepi_2
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Orange Pi 2 (H3)
+ BUILD_DEVICES:=sun8i-h3-orangepi-2
+endef
+
define U-Boot/pangolin
BUILD_SUBTARGET:=cortexa7
NAME:=Theobroma A31-yQ7 devboard
@@ -185,6 +191,7 @@ UBOOT_TARGETS := \
nanopi_neo \
orangepi_r1 \
orangepi_plus \
+ orangepi_2 \
pangolin \
pine64_plus