aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi
diff options
context:
space:
mode:
authorAleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>2019-02-20 14:17:45 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-26 23:20:04 +0100
commit00d89b4a89936cfb86aa57fbb99f33efda80981f (patch)
treec30385d31f88dca417caac79f41303c91b4dd8ef /package/boot/uboot-sunxi
parent4ecf2ee4a0d375d198f515c3e038de62323e0b85 (diff)
downloadupstream-00d89b4a89936cfb86aa57fbb99f33efda80981f.tar.gz
upstream-00d89b4a89936cfb86aa57fbb99f33efda80981f.tar.bz2
upstream-00d89b4a89936cfb86aa57fbb99f33efda80981f.zip
sunxi: add support for Orange Pi One
CPU: H3 Quad-core Cortex-A7 H.265/HEVC 4K @ 1.2 Ghz GPU: Mali400MP2 GPU @ 600MHz (supports OpenGL ES 2.0) Memory: 512MB DDR3 (shared with GPU) Onboard: Storage TF card (Max. 64GB) / MMC card slot Onboard header: SPI, I2C, GPIO, UART USB 2.0: One USB 2.0 HOST, One USB 2.0 OTG Signed-off-by: Aleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>
Diffstat (limited to 'package/boot/uboot-sunxi')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 1d920507c7..1e3883dfb4 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -156,6 +156,12 @@ define U-Boot/orangepi_zero
BUILD_DEVICES:=sun8i-h2-plus-orangepi-zero
endef
+define U-Boot/orangepi_one
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Orange Pi One (H3)
+ BUILD_DEVICES:=sun8i-h3-orangepi-one
+endef
+
define U-Boot/orangepi_pc
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi PC (H3)
@@ -260,6 +266,7 @@ UBOOT_TARGETS := \
nanopi_neo2 \
orangepi_zero \
orangepi_r1 \
+ orangepi_one \
orangepi_pc \
orangepi_plus \
orangepi_2 \