aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-06-09 18:40:16 +0200
committerJohn Crispin <john@phrozen.org>2018-06-18 07:10:20 +0200
commitf2135e7811fec7174f5a74bc579a6a8f936d1100 (patch)
tree341f8bf3695aa505400854ba1adf11a316dbdfe5 /package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch
parent7afe1caf7000f4ca671d3d681feef11af01e8551 (diff)
downloadupstream-f2135e7811fec7174f5a74bc579a6a8f936d1100.tar.gz
upstream-f2135e7811fec7174f5a74bc579a6a8f936d1100.tar.bz2
upstream-f2135e7811fec7174f5a74bc579a6a8f936d1100.zip
uboot-sunxi: update to version 2018.05
This patch 220-add-sunxi50i-nanopi-neo-plus2.patch was merged upstream. The u-boot-sunxi-with-spl.bin is now also created for the ARM64 sunxi boards by U-Boot itself, no need to do it manually any more. This was tested on a H2+ Orange Pi R1 and a H5 Orange Pi Zero Plus. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch')
-rw-r--r--package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch21
1 files changed, 15 insertions, 6 deletions
diff --git a/package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch b/package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch
index b9cd9c7ac0..24b8634110 100644
--- a/package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch
+++ b/package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch
@@ -12,17 +12,26 @@ old way of generating images.
--- a/Makefile
+++ b/Makefile
-@@ -1144,9 +1144,10 @@ u-boot-x86-16bit.bin: u-boot FORCE
- endif
+@@ -1215,8 +1215,10 @@ endif
ifneq ($(CONFIG_ARCH_SUNXI),)
--u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb \
-- checkbinman FORCE
+ ifeq ($(CONFIG_ARM64),)
+-u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb FORCE
- $(call if_changed,binman)
+OBJCOPYFLAGS_u-boot-sunxi-with-spl.bin = -I binary -O binary \
+ --pad-to=$(CONFIG_SPL_PAD_TO) --gap-fill=0xff
+u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img FORCE
+ $(call if_changed,pad_cat)
- endif
+ else
+ u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.itb FORCE
+ $(call if_changed,cat)
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -711,7 +711,6 @@ config ARCH_SOCFPGA
- ifneq ($(CONFIG_TEGRA),)
+ config ARCH_SUNXI
+ bool "Support sunxi (Allwinner) SoCs"
+- select BINMAN
+ select CMD_GPIO
+ select CMD_MMC if MMC
+ select CMD_USB if DISTRO_DEFAULTS