aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
authorChukun Pan <amadeus@jmu.edu.cn>2021-10-16 18:02:40 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-30 21:17:20 +0200
commite43eb16efe97a597a2ebaa9f549d1daec2c8c2ab (patch)
treec57871df6ebb20973d7d9649d315e3d44ad51075 /package/boot/uboot-sunxi/Makefile
parentcc2a8c25459f437e82b58b1bb94afd811cbb131f (diff)
downloadupstream-e43eb16efe97a597a2ebaa9f549d1daec2c8c2ab.tar.gz
upstream-e43eb16efe97a597a2ebaa9f549d1daec2c8c2ab.tar.bz2
upstream-e43eb16efe97a597a2ebaa9f549d1daec2c8c2ab.zip
uboot-sunxi: add support for FriendlyARM NanoPi R1S H5
Merged in https://github.com/u-boot/u-boot/commit/e7510d2, adjust back to the current 2020.04 version. Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 9dce3e448a..5c27407d15 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -270,6 +270,15 @@ define U-Boot/nanopi_neo2
ATF:=a64
endef
+define U-Boot/nanopi_r1s_h5
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=NanoPi R1S (H5)
+ BUILD_DEVICES:=friendlyarm_nanopi-r1s-h5
+ DEPENDS:=+PACKAGE_u-boot-nanopi_r1s_h5:arm-trusted-firmware-sunxi-a64
+ UENV:=a64
+ ATF:=a64
+endef
+
define U-Boot/pine64_plus
BUILD_SUBTARGET:=cortexa53
NAME:=Pine64 Plus A64
@@ -357,6 +366,7 @@ UBOOT_TARGETS := \
nanopi_neo_plus2 \
nanopi_neo2 \
nanopi_r1 \
+ nanopi_r1s_h5 \
orangepi_zero \
orangepi_r1 \
orangepi_one \