aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
authorJayantajit Gogoi <jayanta.gogoi525@gmail.com>2020-10-12 18:51:34 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2020-10-18 15:46:42 +0200
commite6d9f6fdffc6730cfa2019788afa411828eac816 (patch)
treef3b4127aee433b0373d1490e7a96f121186fe5a2 /package/boot/uboot-sunxi/Makefile
parent4ff7bdfeebd4c974b74df74f779fc10891898f5d (diff)
downloadupstream-e6d9f6fdffc6730cfa2019788afa411828eac816.tar.gz
upstream-e6d9f6fdffc6730cfa2019788afa411828eac816.tar.bz2
upstream-e6d9f6fdffc6730cfa2019788afa411828eac816.zip
sunxi: add support for FriendlyARM NanoPi R1
Specification: - CPU: Allwinner H3, Quad-core Cortex-A7 Up to 1.2GHz - DDR3 RAM: 512MB/1GB - Network: 10/100/1000M Ethernet x 1, 10/100M Ethernet x 1 - WiFi: 802.11b/g/n, with SMA antenna interface - USB Host: Type-A x2 - MicroSD Slot x 1 - MicroUSB: for OTG and power input - Debug Serial Port: 3Pin 2.54mm pitch pin-header - LED: nanopi:red:status nanopi:green:wan nanopi:green:lan - KEY: reset - Power Supply: DC 5V/2A Installation: - Write the image to SD Card with dd - Boot NanoPi from the SD Card Signed-off-by: Jayantajit Gogoi <jayanta.gogoi525@gmail.com>
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 4363445114..abdb263774 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -172,6 +172,12 @@ define U-Boot/nanopi_neo
BUILD_DEVICES:=friendlyarm_nanopi-neo
endef
+define U-Boot/nanopi_r1
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=U-Boot for NanoPi R1 (H3)
+ BUILD_DEVICES:=friendlyarm_nanopi-r1
+endef
+
define U-Boot/orangepi_r1
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi R1 (H2+)
@@ -310,6 +316,7 @@ UBOOT_TARGETS := \
nanopi_neo_air \
nanopi_neo_plus2 \
nanopi_neo2 \
+ nanopi_r1 \
orangepi_zero \
orangepi_r1 \
orangepi_one \