aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-09-26 22:41:56 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-01 17:10:33 +0200
commit5508510e744ce9dfaba23cb8639977f021bd29f9 (patch)
tree97030cac2a65c0f9c1821a9d043f16a9986f1a91 /package/boot/uboot-sunxi/Makefile
parentba1aedafebcb5cb577c69d412ee3d4de262ccc32 (diff)
downloadupstream-5508510e744ce9dfaba23cb8639977f021bd29f9.tar.gz
upstream-5508510e744ce9dfaba23cb8639977f021bd29f9.tar.bz2
upstream-5508510e744ce9dfaba23cb8639977f021bd29f9.zip
sunxi: add Orange Pi R1 support
The following features are working and tested: * both Ethernet ports * MMC * LED The following features are not working: * Wifi (There is a crappy driver we could port) * SPI flash (I haven't looked into this) I haven't tried out the rest. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 8b073497a5..13fb8cb188 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -126,6 +126,12 @@ define U-Boot/Lamobo_R1
BUILD_DEVICES:=sun7i-a20-lamobo-r1
endef
+define U-Boot/orangepi_r1
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Orange Pi R1 (H2+)
+ BUILD_DEVICES:=sun8i-h2-plus-orangepi-r1
+endef
+
define U-Boot/orangepi_plus
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi Plus (H3)
@@ -164,6 +170,7 @@ UBOOT_TARGETS := \
Linksprite_pcDuino \
Linksprite_pcDuino3 \
Lamobo_R1 \
+ orangepi_r1 \
orangepi_plus \
pangolin \
pine64_plus