aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2014-01-31 15:53:53 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2014-01-31 15:53:53 +0000
commit34c49dcc5ee400efe1a4ebcee8ac07a2acce8256 (patch)
treed4fee08614e634ebe4a4f451990bc2911b6574d7 /package/boot/uboot-sunxi/Makefile
parentce73f9f14582d13aca15d1572ec229de802e8dea (diff)
downloadupstream-34c49dcc5ee400efe1a4ebcee8ac07a2acce8256.tar.gz
upstream-34c49dcc5ee400efe1a4ebcee8ac07a2acce8256.tar.bz2
upstream-34c49dcc5ee400efe1a4ebcee8ac07a2acce8256.zip
sunxi: boot changes
- Added uEnv.txt to facilitate automatic boot. - Cosmetic fix in u-boot Makefile - Don't force command line arguments Signed-off-by: Zalan Blenessy <zalan.blenessy@gmail.com> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39438 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index cedf2c454b..796a6045cc 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -98,9 +98,11 @@ define Package/uboot/install/default
$(CP) $(PKG_BUILD_DIR)/u-boot.bin \
$(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.bin
$(CP) $(PKG_BUILD_DIR)/spl/sunxi-spl.bin \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-sunxi-spl.bin
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-spl.bin
$(CP) $(PKG_BUILD_DIR)/u-boot-sunxi-with-spl.bin \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-sunxi-with-spl.bin
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot-with-spl.bin
+ $(CP) uEnv.txt \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-uEnv.txt
endef
define Package/uboot/install/template