aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-rockchip/Makefile
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-04-07 23:46:43 +0800
committerTianling Shen <cnsztl@immortalwrt.org>2023-05-09 13:30:22 +0800
commitb95c2146838403b68fb8b487e7f890ddefb4fb8d (patch)
treefdadbf9fda6b495ecd5249d6d0c166c6c883ffec /package/boot/uboot-rockchip/Makefile
parent7bfe7e06767767914f42785d12d2fceca189854e (diff)
downloadupstream-b95c2146838403b68fb8b487e7f890ddefb4fb8d.tar.gz
upstream-b95c2146838403b68fb8b487e7f890ddefb4fb8d.tar.bz2
upstream-b95c2146838403b68fb8b487e7f890ddefb4fb8d.zip
uboot-rockchip: add ROC-RK3328-CC support
Add support for the Firefly ROC-RK3328-CC. Manually generated of-platdata files to avoid swig dependency. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'package/boot/uboot-rockchip/Makefile')
-rw-r--r--package/boot/uboot-rockchip/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/boot/uboot-rockchip/Makefile b/package/boot/uboot-rockchip/Makefile
index 441028fe7f..e22a7cf037 100644
--- a/package/boot/uboot-rockchip/Makefile
+++ b/package/boot/uboot-rockchip/Makefile
@@ -35,6 +35,16 @@ define U-Boot/nanopi-r2s-rk3328
OF_PLATDATA:=$(1)
endef
+define U-Boot/roc-cc-rk3328
+ BUILD_SUBTARGET:=armv8
+ NAME:=ROC-RK3328-CC
+ BUILD_DEVICES:= \
+ firefly_roc-rk3328-cc
+ DEPENDS:=+PACKAGE_u-boot-roc-cc-rk3328:arm-trusted-firmware-rockchip
+ PKG_BUILD_DEPENDS:=arm-trusted-firmware-rockchip
+ ATF:=rk3328_bl31.elf
+ OF_PLATDATA:=$(1)
+endef
# RK3399 boards
@@ -72,7 +82,8 @@ UBOOT_TARGETS := \
nanopi-r4s-rk3399 \
rock-pi-4-rk3399 \
rockpro64-rk3399 \
- nanopi-r2s-rk3328
+ nanopi-r2s-rk3328 \
+ roc-cc-rk3328
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes