aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-rockchip/Makefile
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-30 12:59:07 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-06-09 13:15:19 +0200
commit3b8564f9aa3361589f0f87c3e9a635fd4a56d5ac (patch)
treea207340869a5f35fc4746cada9c8c8f2287de67b /package/boot/uboot-rockchip/Makefile
parentc11115b5cff2b67ee73da50d864e6443e7124812 (diff)
downloadupstream-3b8564f9aa3361589f0f87c3e9a635fd4a56d5ac.tar.gz
upstream-3b8564f9aa3361589f0f87c3e9a635fd4a56d5ac.tar.bz2
upstream-3b8564f9aa3361589f0f87c3e9a635fd4a56d5ac.zip
uboot-rockchip: add Orange Pi R1 Plus LTS support
Add support for the Xunlong Orange Pi R1 Plus LTS. Manually generated of-platdata files to avoid swig dependency. Tested-by: Volkan Yetik <no3iverson@gmail.com> Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org> (cherry picked from commit 37fed89166e6e21c20ef92b36106f7184a0476c6)
Diffstat (limited to 'package/boot/uboot-rockchip/Makefile')
-rw-r--r--package/boot/uboot-rockchip/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/boot/uboot-rockchip/Makefile b/package/boot/uboot-rockchip/Makefile
index 126af6ac54..59b8be84cf 100644
--- a/package/boot/uboot-rockchip/Makefile
+++ b/package/boot/uboot-rockchip/Makefile
@@ -52,6 +52,13 @@ define U-Boot/orangepi-r1-plus-rk3328
xunlong_orangepi-r1-plus
endef
+define U-Boot/orangepi-r1-plus-lts-rk3328
+ $(U-Boot/rk3328/Default)
+ NAME:=Orange Pi R1 Plus LTS
+ BUILD_DEVICES:= \
+ xunlong_orangepi-r1-plus-lts
+endef
+
define U-Boot/roc-cc-rk3328
$(U-Boot/rk3328/Default)
NAME:=ROC-RK3328-CC
@@ -95,6 +102,7 @@ UBOOT_TARGETS := \
nanopi-r2c-rk3328 \
nanopi-r2s-rk3328 \
orangepi-r1-plus-rk3328 \
+ orangepi-r1-plus-lts-rk3328 \
roc-cc-rk3328
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes