aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-omap
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-04-18 20:15:59 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-04-24 18:03:31 +0200
commit147e18bdbdb5ac093d06c3a7e400b20969b7a5f5 (patch)
tree220d30ab2d507423c20a805d993e8cdaee7321e8 /package/boot/uboot-omap
parente2caa74a2ffece85c302960f4994776427db4e38 (diff)
downloadupstream-147e18bdbdb5ac093d06c3a7e400b20969b7a5f5.tar.gz
upstream-147e18bdbdb5ac093d06c3a7e400b20969b7a5f5.tar.bz2
upstream-147e18bdbdb5ac093d06c3a7e400b20969b7a5f5.zip
package/uboot-omap: re-introduce patches dropped by update to v2017.01
The beagleboard doesn't boot with Thumb enabled, but without Thumb the SPL (first stage bootloader) is too big to fit into SRAM. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'package/boot/uboot-omap')
-rw-r--r--package/boot/uboot-omap/patches/101-disable-thumb-beagleboard.patch14
-rw-r--r--package/boot/uboot-omap/patches/102-minify-spl.patch44
-rw-r--r--package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch27
3 files changed, 85 insertions, 0 deletions
diff --git a/package/boot/uboot-omap/patches/101-disable-thumb-beagleboard.patch b/package/boot/uboot-omap/patches/101-disable-thumb-beagleboard.patch
new file mode 100644
index 0000000000..8a3b024fe4
--- /dev/null
+++ b/package/boot/uboot-omap/patches/101-disable-thumb-beagleboard.patch
@@ -0,0 +1,14 @@
+Index: u-boot-2017.01/include/configs/ti_omap3_common.h
+===================================================================
+--- u-boot-2017.01.orig/include/configs/ti_omap3_common.h
++++ u-boot-2017.01/include/configs/ti_omap3_common.h
+@@ -80,4 +80,9 @@
+ /* Now bring in the rest of the common code. */
+ #include <configs/ti_armv7_omap.h>
+
++/* beagleboard doesnt boot with thumb */
++#ifdef CONFIG_SYS_THUMB_BUILD
++#undef CONFIG_SYS_THUMB_BUILD
++#endif
++
+ #endif /* __CONFIG_TI_OMAP3_COMMON_H__ */
diff --git a/package/boot/uboot-omap/patches/102-minify-spl.patch b/package/boot/uboot-omap/patches/102-minify-spl.patch
new file mode 100644
index 0000000000..66f6b6b59f
--- /dev/null
+++ b/package/boot/uboot-omap/patches/102-minify-spl.patch
@@ -0,0 +1,44 @@
+Index: u-boot-2017.01/configs/omap3_beagle_defconfig
+===================================================================
+--- u-boot-2017.01.orig/configs/omap3_beagle_defconfig
++++ u-boot-2017.01/configs/omap3_beagle_defconfig
+@@ -7,7 +7,7 @@ CONFIG_SYS_CONSOLE_INFO_QUIET=y
+ CONFIG_VERSION_VARIABLE=y
+ CONFIG_SPL=y
+ CONFIG_SPL_MTD_SUPPORT=y
+-CONFIG_SPL_OS_BOOT=y
++# CONFIG_SPL_EXT_SUPPORT is not set
+ # CONFIG_CMD_IMLS is not set
+ CONFIG_CMD_ASKENV=y
+ # CONFIG_CMD_FLASH is not set
+Index: u-boot-2017.01/common/Makefile
+===================================================================
+--- u-boot-2017.01.orig/common/Makefile
++++ u-boot-2017.01/common/Makefile
+@@ -174,8 +174,11 @@ obj-$(CONFIG_CMDLINE) += cli_simple.o
+ obj-y += cli.o
+ obj-$(CONFIG_CMDLINE) += cli_readline.o
+ obj-$(CONFIG_CMD_DFU) += dfu.o
++
++ifndef CONFIG_SPL_BUILD
+ obj-y += command.o
+ obj-y += s_record.o
+ obj-y += xyzModem.o
++endif
+
+ CFLAGS_env_embedded.o := -Wa,--no-warn -DENV_CRC=$(shell tools/envcrc 2>/dev/null)
+Index: u-boot-2017.01/cmd/Makefile
+===================================================================
+--- u-boot-2017.01.orig/cmd/Makefile
++++ u-boot-2017.01/cmd/Makefile
+@@ -161,7 +161,10 @@ endif # !CONFIG_SPL_BUILD
+
+ obj-$(CONFIG_CMD_BLOB) += blob.o
+
++
++# ifndef CONFIG_SPL_BUILD
+ # core command
+ obj-y += nvedit.o
++# endif # !CONFIG_SPL_BUILD
+
+ obj-$(CONFIG_ARCH_MVEBU) += mvebu/
diff --git a/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch b/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
new file mode 100644
index 0000000000..89b02044dc
--- /dev/null
+++ b/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
@@ -0,0 +1,27 @@
+Index: u-boot-2017.01/fs/fat/Makefile
+===================================================================
+--- u-boot-2017.01.orig/fs/fat/Makefile
++++ u-boot-2017.01/fs/fat/Makefile
+@@ -4,8 +4,8 @@
+ #
+
+ obj-$(CONFIG_FS_FAT) := fat.o
+-obj-$(CONFIG_FAT_WRITE):= fat_write.o
+
+ ifndef CONFIG_SPL_BUILD
++obj-$(CONFIG_FAT_WRITE):= fat_write.o
+ obj-$(CONFIG_FS_FAT) += file.o
+ endif
+Index: u-boot-2017.01/fs/fat/fat.c
+===================================================================
+--- u-boot-2017.01.orig/fs/fat/fat.c
++++ u-boot-2017.01/fs/fat/fat.c
+@@ -163,7 +163,7 @@ static void get_name(dir_entry *dirent,
+ }
+
+ static int flush_dirty_fat_buffer(fsdata *mydata);
+-#if !defined(CONFIG_FAT_WRITE)
++#if !defined(CONFIG_FAT_WRITE) || defined(CONFIG_SPL_BUILD)
+ /* Stub for read only operation */
+ int flush_dirty_fat_buffer(fsdata *mydata)
+ {