aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-omap
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-04-19 04:48:03 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-04-24 18:03:31 +0200
commita5eb9c6370f5e1f38c9429b0c46f757706eac0c7 (patch)
tree7b1145efdc91d1519f4a70d67ca17407c2327551 /package/boot/uboot-omap
parent147e18bdbdb5ac093d06c3a7e400b20969b7a5f5 (diff)
downloadupstream-a5eb9c6370f5e1f38c9429b0c46f757706eac0c7.tar.gz
upstream-a5eb9c6370f5e1f38c9429b0c46f757706eac0c7.tar.bz2
upstream-a5eb9c6370f5e1f38c9429b0c46f757706eac0c7.zip
package/uboot-omap: add default uEnv to boot via mmc card
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'package/boot/uboot-omap')
-rw-r--r--package/boot/uboot-omap/Makefile2
-rw-r--r--package/boot/uboot-omap/files/uEnv-default.txt8
2 files changed, 10 insertions, 0 deletions
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index 17a4af42f2..d11ced4351 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -19,6 +19,7 @@ include $(INCLUDE_DIR)/package.mk
define U-Boot/Default
BUILD_TARGET:=omap
UBOOT_IMAGE:=u-boot.img MLO
+ UENV:=default
endef
define U-Boot/omap4_panda
@@ -45,6 +46,7 @@ UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)
$(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)/
+ $(CP) ./files/uEnv-$(UENV).txt $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)/uEnv.txt
endef
$(eval $(call BuildPackage/U-Boot))
diff --git a/package/boot/uboot-omap/files/uEnv-default.txt b/package/boot/uboot-omap/files/uEnv-default.txt
new file mode 100644
index 0000000000..3584e4379b
--- /dev/null
+++ b/package/boot/uboot-omap/files/uEnv-default.txt
@@ -0,0 +1,8 @@
+bootpart=0:1
+bootdir=/
+bootfile=zImage
+fdtdir=/dtbs
+uenvcmd=run loadfdt; run loadimage; run uenvbootargs ; bootz ${loadaddr} - ${fdtaddr}
+loadfdt=load mmc ${bootpart} ${fdtaddr} ${fdtdir}/${fdtfile}
+devtype=mmc
+uenvbootargs=setenv bootargs console=${console} root=/dev/mmcblk0p2