aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-omap/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2019-09-06 22:53:23 +0200
committerAlexander Couzens <lynxis@fe80.eu>2019-11-20 10:46:19 +0100
commit1f37b2226ed3f5142906cdabd50e94d77e30505b (patch)
treef698846e6c2b8d4cf10e7e345317e37fa85d683f /package/boot/uboot-omap/Makefile
parentb69df1eee0eb4618355d5ea4d0cdb4553475c4b7 (diff)
downloadupstream-1f37b2226ed3f5142906cdabd50e94d77e30505b.tar.gz
upstream-1f37b2226ed3f5142906cdabd50e94d77e30505b.tar.bz2
upstream-1f37b2226ed3f5142906cdabd50e94d77e30505b.zip
omap: switch from uEnv.txt to generic distro booting
Which makes supporting different boot devices easy. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot/uboot-omap/Makefile')
-rw-r--r--package/boot/uboot-omap/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index b519d6fb80..70c8af1dc4 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -19,7 +19,6 @@ include $(INCLUDE_DIR)/package.mk
define U-Boot/Default
BUILD_TARGET:=omap
UBOOT_IMAGE:=u-boot.img MLO
- UENV:=default
endef
define U-Boot/omap4_panda
@@ -51,7 +50,8 @@ define Build/InstallDev
$(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(device)/
)
$(foreach device,$(BUILD_DEVICES), \
- $(CP) ./files/uEnv-$(UENV).txt $(STAGING_DIR_IMAGE)/$(device)/uEnv.txt
+ mkimage -C none -A arm -T script -d ./files/boot.scr.txt \
+ $(STAGING_DIR_IMAGE)/$(device)/boot.scr
)
endef