aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mxs/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-27 16:26:56 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-27 16:53:31 +0100
commite0579aecf8de03dd7e529fa14193557014554699 (patch)
tree3f48590f077ade7ee86167f63ae15c1ea9ec6431 /package/boot/uboot-mxs/Makefile
parent7f9d537f21f2bd79a8b5bfd86c50629c76b306dc (diff)
downloadupstream-e0579aecf8de03dd7e529fa14193557014554699.tar.gz
upstream-e0579aecf8de03dd7e529fa14193557014554699.tar.bz2
upstream-e0579aecf8de03dd7e529fa14193557014554699.zip
mxs: put u-boot images into image staging directory
Do not put the u-boot images into the kernel build directory as this directory might get removed after kernel updates while the u-boot packages InstallDev recipe is not getting re-executed because it is still considered current, leading to image build failures later on due to missing images. To ensure that built bootloader images persist over kernel version updates in the buildroot, put them into the new STAGING_DIR_IMAGE directory. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/boot/uboot-mxs/Makefile')
-rw-r--r--package/boot/uboot-mxs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index eec78417f2..92cf9e6b27 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -38,7 +38,8 @@ UBOOT_TARGETS := \
UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)
define Build/InstallDev
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)
endef
$(eval $(call BuildPackage/U-Boot))