aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mxs/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-02-17 15:38:26 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-17 23:22:40 +0100
commit5d3fbd59962981676a61d2c667870d5fbb67535f (patch)
tree451f7d6b61d1e793218e5c3d011a04b0b6633131 /package/boot/uboot-mxs/Makefile
parent8cc22fad6afb54d1020ddb2ca24ae7ed6ab5b602 (diff)
downloadupstream-5d3fbd59962981676a61d2c667870d5fbb67535f.tar.gz
upstream-5d3fbd59962981676a61d2c667870d5fbb67535f.tar.bz2
upstream-5d3fbd59962981676a61d2c667870d5fbb67535f.zip
uboot-mxs: fix compile problems related to OpenSSL
Use the UBOOT_MAKE_FLAGS defined in include/u-boot.mk and do not overwrite them to compile the host tools against the shipped LibreSSL. In addition add a patch to fix a compile problem when compiling the tools against LibreSSL caused by differences in the API between OpenSSL 1.1 and LibreSSL. This should fix the compile problems seen in build bot from time to time by not depending on the host libssl-dev package any more but using the LibreSSL version from OpenWrt. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/boot/uboot-mxs/Makefile')
-rw-r--r--package/boot/uboot-mxs/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index 6fde52ef56..cd752bb81a 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -35,7 +35,7 @@ UBOOT_TARGETS := \
mx23_olinuxino \
duckbill
-UBOOT_MAKE_FLAGS = $(UBOOT_IMAGE)
+UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)