aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mxs/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-25 07:31:01 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-25 07:48:43 +0100
commit07c9bde0da177754ac5bf0865610b308e080a238 (patch)
tree4d5ed1c3dd8e082a4c3ef3621dcc4e4c6c006359 /package/boot/uboot-mxs/Makefile
parent1c0addb15608b7a0d73fd056524f505df02eb5e3 (diff)
downloadupstream-07c9bde0da177754ac5bf0865610b308e080a238.tar.gz
upstream-07c9bde0da177754ac5bf0865610b308e080a238.tar.bz2
upstream-07c9bde0da177754ac5bf0865610b308e080a238.zip
mxs: fix image build issues
stage u-boot images in KERNEL_BUILD_DIR for building images always select uboot-mxs Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/boot/uboot-mxs/Makefile')
-rw-r--r--package/boot/uboot-mxs/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index 66459df652..eec78417f2 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -6,6 +6,7 @@
#
include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_VERSION:=2016.01
PKG_RELEASE:=1
@@ -18,6 +19,8 @@ include $(INCLUDE_DIR)/package.mk
define U-Boot/Default
BUILD_TARGET:=mxs
UBOOT_IMAGE:=u-boot.sb
+ DEFAULT:=y
+ HIDDEN:=1
endef
define U-Boot/mx23_olinuxino
@@ -32,9 +35,10 @@ UBOOT_TARGETS := \
mx23_olinuxino \
duckbill
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CROSS_COMPILE=$(TARGET_CROSS) $(UBOOT_IMAGE)
+UBOOT_MAKE_FLAGS += $(UBOOT_IMAGE)
+
+define Build/InstallDev
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)
endef
$(eval $(call BuildPackage/U-Boot))