aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/patches/100-fix-build.patch
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2022-07-11 19:49:21 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-08-06 22:25:43 +0200
commit39ac29a68aba382f052214c18d2da60bd4816fbe (patch)
tree95a38d9f7013999b9695098d4542d94302fed625 /package/boot/uboot-mvebu/patches/100-fix-build.patch
parentec8b5cf0e6a858938f409f4bad138a95a1de78e5 (diff)
downloadupstream-39ac29a68aba382f052214c18d2da60bd4816fbe.tar.gz
upstream-39ac29a68aba382f052214c18d2da60bd4816fbe.tar.bz2
upstream-39ac29a68aba382f052214c18d2da60bd4816fbe.zip
uboot-mvebu: update to v2022.07
- Release announcement: https://lore.kernel.org/u-boot/20220711134339.GV1146598@bill-the-cat/ - Changes between 2022.04 and 2022.07: https://source.denx.de/u-boot/u-boot/-/compare/v2022.04...v2022.07?from_project_id=531 Remove one upstreamed patch and add patch to fix issue with sunxi tool as it uses function from newer version libressl (3.5.0). Signed-off-by: Andre Heider <a.heider@gmail.com> Tested-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [Turris Omnia] (cherry picked from commit 24bf6813bad98a8eba5430ed5e4da89d54797274) Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [Improve commit message]
Diffstat (limited to 'package/boot/uboot-mvebu/patches/100-fix-build.patch')
-rw-r--r--package/boot/uboot-mvebu/patches/100-fix-build.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/patches/100-fix-build.patch b/package/boot/uboot-mvebu/patches/100-fix-build.patch
new file mode 100644
index 0000000000..c39f5bf1dc
--- /dev/null
+++ b/package/boot/uboot-mvebu/patches/100-fix-build.patch
@@ -0,0 +1,20 @@
+The build fails on a sunxi tool:
+
+/usr/bin/ld: tools/sunxi_toc0.o: in function `toc0_set_header':
+sunxi_toc0.c:(.text+0x363): undefined reference to `RSA_get0_d'
+
+The missing function was added in libressl v3.5.0. We don't
+really care, so just cut it out for now.
+
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -96,8 +96,7 @@ AES_OBJS-$(CONFIG_TOOLS_LIBCRYPTO) := $(
+
+ # Cryptographic helpers and image types that depend on openssl/libcrypto
+ LIBCRYPTO_OBJS-$(CONFIG_TOOLS_LIBCRYPTO) := \
+- lib/fdt-libcrypto.o \
+- sunxi_toc0.o
++ lib/fdt-libcrypto.o
+
+ ROCKCHIP_OBS = lib/rc4.o rkcommon.o rkimage.o rksd.o rkspi.o
+