aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/Makefile
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2022-01-28 13:37:08 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-02-03 21:24:26 +0100
commit5c804bc199e43e7d41af3242cba950f88bb29807 (patch)
tree53798311a4692bf7f1ee740e254f5e29e09e9de0 /package/boot/uboot-mvebu/Makefile
parent782d4c8306c89fc8b7e98601acc5b6da0bd596bb (diff)
downloadupstream-5c804bc199e43e7d41af3242cba950f88bb29807.tar.gz
upstream-5c804bc199e43e7d41af3242cba950f88bb29807.tar.bz2
upstream-5c804bc199e43e7d41af3242cba950f88bb29807.zip
uboot-mvebu: Add U-boot for Turris Omnia
* Add U-boot support for Turris Omnia Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'package/boot/uboot-mvebu/Makefile')
-rw-r--r--package/boot/uboot-mvebu/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 3550ab0611..566f45ffed 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -36,6 +36,14 @@ define U-Boot/helios4
UBOOT_IMAGE:=u-boot-spl.kwb
endef
+define U-Boot/omnia
+ NAME:=Turris Omnia
+ BUILD_DEVICES:=cznic_turris-omnia
+ BUILD_SUBTARGET:=cortexa9
+ UBOOT_CONFIG:=turris_omnia
+ UBOOT_IMAGE:=u-boot-spl.kwb
+endef
+
define U-Boot/espressobin
NAME:=Marvell ESPRESSObin
BUILD_SUBTARGET:=cortexa53
@@ -50,6 +58,7 @@ endef
UBOOT_TARGETS:= \
clearfog \
helios4 \
+ omnia \
espressobin \
uDPU