aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/Makefile
diff options
context:
space:
mode:
authorJosua Mayer <josua.mayer97@gmail.com>2018-03-21 00:10:17 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-31 16:12:39 +0200
commit0a3e07b2f5a5a8b20da173663007cb1f4b8f3eb8 (patch)
tree39202313b8ac1991d66f73939f5cb3c42e8b23f1 /package/boot/uboot-mvebu/Makefile
parent4b486e32fb34567fe8b04aea552225db699813e1 (diff)
downloadupstream-0a3e07b2f5a5a8b20da173663007cb1f4b8f3eb8.tar.gz
upstream-0a3e07b2f5a5a8b20da173663007cb1f4b8f3eb8.tar.bz2
upstream-0a3e07b2f5a5a8b20da173663007cb1f4b8f3eb8.zip
u-boot-mvebu: set configuration options in Makefile
CONFIG_* variables can easily be set by overriding Build/Configure. so set NET_RANDOM_ETHADDR=y and CMD_SETEXPR=y here. This replaces the following patches: 0001-clearfog-generate-random-MAC-address.patch 0004-clearfog-enable-setexpr-command-by-default.patch Signed-off-by: Josua Mayer <josua.mayer97@gmail.com>
Diffstat (limited to 'package/boot/uboot-mvebu/Makefile')
-rw-r--r--package/boot/uboot-mvebu/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 53abcafda0..cb48b67406 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -31,6 +31,14 @@ endef
UBOOT_TARGETS:= \
clearfog
+define Build/Configure
+ # enable additional options beyond clearfog_defconfig
+ echo CONFIG_NET_RANDOM_ETHADDR=y >> $(PKG_BUILD_DIR)/configs/$(BUILD_VARIANT)_defconfig
+ echo CONFIG_CMD_SETEXPR=y >> $(PKG_BUILD_DIR)/configs/$(BUILD_VARIANT)_defconfig
+
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIGURE_VARS) $(UBOOT_CONFIG)_config
+endef
+
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-u-boot-spl.kwb