aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2019-11-02 13:14:08 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2020-09-18 21:42:05 +0200
commit72bb66caad5ac79294c92cb1ca115942b59080e1 (patch)
treeaf0ade5dfdaa9d53a69b082e00243bfc1dfde3ee /package/boot/uboot-mvebu/Makefile
parentae2e521b34ca3504e7f32898dcd7e1c71707d206 (diff)
downloadupstream-72bb66caad5ac79294c92cb1ca115942b59080e1.tar.gz
upstream-72bb66caad5ac79294c92cb1ca115942b59080e1.tar.bz2
upstream-72bb66caad5ac79294c92cb1ca115942b59080e1.zip
uboot-mvebu: add support for espressobin
This builds two u-boot binaries: one for boards without eMMC and one with. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot/uboot-mvebu/Makefile')
-rw-r--r--package/boot/uboot-mvebu/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 8db3c1272d..9a1b5ed63d 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -36,6 +36,21 @@ define U-Boot/helios4
UBOOT_IMAGE:=u-boot-spl.kwb
endef
+define U-Boot/espressobin
+ NAME:=Marvell ESPRESSObin
+ BUILD_DEVICES:=globalscale_espressobin globalscale_espressobin-v7
+ BUILD_SUBTARGET:=cortexa53
+ UBOOT_CONFIG:=mvebu_espressobin-88f3720
+endef
+
+define U-Boot/espressobin-emmc
+ NAME:=Marvell ESPRESSObin
+ BUILD_DEVICES:=globalscale_espressobin-emmc globalscale_espressobin-v7-emmc
+ BUILD_SUBTARGET:=cortexa53
+ UBOOT_CONFIG:=mvebu_espressobin-88f3720
+ UBOOT_MAKE_FLAGS+=DEVICE_TREE=armada-3720-espressobin-emmc
+endef
+
define U-Boot/uDPU
NAME:=Methode uDPU
BUILD_DEVICES:=methode_udpu
@@ -45,6 +60,8 @@ endef
UBOOT_TARGETS:= \
clearfog \
helios4 \
+ espressobin \
+ espressobin-emmc \
uDPU
Build/Exports:=$(Host/Exports)