aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/Makefile
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2018-01-23 16:42:09 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-02-10 20:52:31 +0100
commita6f79f5e5e97acb9013c600c4878e18f3c606513 (patch)
treef09473767bb8995cfc67726ce815a7c77fcec869 /package/boot/uboot-mvebu/Makefile
parentc72e6582c073b489348df3fedb273456d504559f (diff)
downloadupstream-a6f79f5e5e97acb9013c600c4878e18f3c606513.tar.gz
upstream-a6f79f5e5e97acb9013c600c4878e18f3c606513.tar.bz2
upstream-a6f79f5e5e97acb9013c600c4878e18f3c606513.zip
uboot-mvebu: fix build ; use the build's tools/libressl
Since I have no openssl-dev on my machine, I first get this error: ``` tools/kwbimage.c:21:10: fatal error: openssl/bn.h: No such file or directory #include <openssl/bn.h> ``` After removing the UBOOT_MAKE_FLAGS the next error is: ``` tools/kwbimage.c:40:6: error: conflicting types for ‘EVP_MD_CTX_cleanup’ void EVP_MD_CTX_cleanup(EVP_MD_CTX *ctx) ``` After removing the OpenSSL patches the next error is: ``` HOSTLD tools/dumpimage /usr/bin/ld: cannot find -lssl /usr/bin/ld: cannot find -lcrypto collect2: error: ld returned 1 exit status scripts/Makefile.host:108: recipe for target 'tools/dumpimage' failed make[5]: *** [tools/dumpimage] Error 1 ``` So, the final part is to add the build system's HOST_LDFLAGS to the UBOOT_MAKE_FLAGS. (which was done in the previous commit) Then the image builds. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'package/boot/uboot-mvebu/Makefile')
-rw-r--r--package/boot/uboot-mvebu/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index b29039cd82..2c280faa21 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -16,8 +16,6 @@ PKG_HASH:=f54baf3f9325bf444c7905f3a5b6f83680edb1e6e1a4d5f8a5ad80abe885113f
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
-UBOOT_MAKE_FLAGS:=
-
define U-Boot/Default
BUILD_TARGET:=mvebu
HIDDEN:=1