aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/Makefile
diff options
context:
space:
mode:
authorVladimir Vid <vladimir.vid@sartura.hr>2019-09-09 18:50:26 +0200
committerLuka Perkov <luka.perkov@sartura.hr>2019-11-21 07:32:41 +0100
commite7a96acf1bd505880133e136e48b09d33344e466 (patch)
tree6cf88592c720ea58144c9eace998dee676e32cde /package/boot/uboot-mvebu/Makefile
parent52459ebf773d6eca1dbf53ab4dbde8c81a3addf0 (diff)
downloadupstream-e7a96acf1bd505880133e136e48b09d33344e466.tar.gz
upstream-e7a96acf1bd505880133e136e48b09d33344e466.tar.bz2
upstream-e7a96acf1bd505880133e136e48b09d33344e466.zip
uboot-mvebu: add uDPU board
* add u-boot support for uDPU * add line to copy u-boot binary to STAGING_DIR_IMAGE, this can later be used as BL33 variable required for ATF build * add patch to increase max gunzip size in mvebu_armada-37xx.h which is required for booting the itb recovery images Signed-off-by: Vladimir Vid <vladimir.vid@sartura.hr>
Diffstat (limited to 'package/boot/uboot-mvebu/Makefile')
-rw-r--r--package/boot/uboot-mvebu/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 07f2508957..d171daa717 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -29,8 +29,15 @@ define U-Boot/clearfog
UBOOT_IMAGE:=u-boot-spl.kwb
endef
+define U-Boot/uDPU
+ NAME:=Methode uDPU
+ BUILD_DEVICES:=methode_udpu
+ BUILD_SUBTARGET:=cortexa53
+endef
+
UBOOT_TARGETS:= \
- clearfog
+ clearfog \
+ uDPU
Build/Exports:=$(Host/Exports)
@@ -44,7 +51,7 @@ endef
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
- $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-u-boot-spl.kwb
+ $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)
endef
$(eval $(call BuildPackage/U-Boot))